Επαναληπτικές Ασκήσεις – Λογικές Εκφράσεις

ΕΙΣΑΓΩΓΗ ΣΤΟΥΣ ΑΛΓΟΡΙΘΜΟΥΣ – ΑΕΠΠ

ΚΕΦΑΛΑΙΟ ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ – ΕΠΙΛΟΓΗΣ

& ΥΠΟΠΡΟΓΡΑΜΜΑΤΑ ΥΝΑΡΤΗΣΕΙΣ)

ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΣΚΗΣΕΙΣ

ΕΠΑΝΑΛΗΨΗ ΑΕΠΠ – ΠΡΟΒΛΗΜΑΤΑ ΒΗΜΑ – ΒΗΜΑ

Βασικό Σενάριο

Ο Δημήτρης με τον φίλο του τον Χρήστο διατηρούν ένα καφέ στην περιοχή της Πυλαίας. Παρέες κοινών φίλων τους έρχονται και περνούν όμορφα το πρωϊνό του Σαββάτου πίνοντας τον καφέ τους. Οι δύο φίλοι αποφασίζουν ότι κάθε παρέα θα δικαιούται μία έκπτωση.

 

1. Γνωστό πλήθος επαναλήψεων – χωρίς επιλογή

Κάθε παρέα δικαιούται έκπτωση 25%.
Να γράφει αλγόριθμος πού για 6 παρέες θα διαβάζει το ποσό του λογαριασμού και θα υπολογίζει την έκπτωση και το τελικό ποσό που κάθε παρέα πρέπει να πληρώσει.

2. Άγνωστο πλήθος επαναλήψεων (με τιμή φρουρό) – χωρίς επιλογή

Να γράφει αλγόριθμος πού για κάθε παρέα θα διαβάζει το ποσό του λογαριασμού και το ποσοστό έκπτωσης και θα υπολογίζει το τελικό ποσό πληρωμής. Ο αλγόριθμος ολοκληρώνεται με την τελευταία παρέα να μην πληρώνει τίποτα -μηδενικός λογαριασμός.

 

3. Γνωστό πλήθος επαναλήψεων με απλή επιλογή

Στο εξής την έκπτωση θα δικαιούνται μόνο όσοι έχουν λογαριασμό μεγαλύτερο των 45 ευρώ. Ο αλγόριθμος διαβάζει στην αρχή το πλήθος των λογαριασμών.

4. Άγνωστο πλήθος επαναλήψεων (με τιμή φρουρό) – με σύνθετη επιλογή

Ο αλγόριθμος ολοκληρώνεται όταν ως ποσό λογαριασμού δοθεί αρνητικός αριθμός. Έκπτωση 25% δικαιούνται όσοι ο λογαριασμός τους ξεπερνά ένα ορισμένο ποσό που δίνεται ως είσοδος στον αλγόριθμο. Οι υπόλοιποι λαμβάνουν επίσης έκπτωση αλλά σε ποσοστό μόλις 10%.

 

 

5. Άγνωστο πλήθος επαναλήψεων – με πολλαπλή επιλογή

Η έκπτωση υπολογίζεται με βάση τον πίνακα που ακολουθεί. Μετά την εκτέλεση των απαραίτητων για κάθε λογαριασμό υπολογισμών ο αλγόριθμος εμφανίζει μήνυμα προς τον χρήστη αν επιθυμεί να συνεχίσει ή όχι. Αναλόγως της απάντησης είτε τερματίζει είτε συνεχίζει με τον επόμενο λογαριασμό.

Ποσό λογαριασμού Ποσοστό Έκπτωσης
μέχρι 25 € 5%
μεταξύ 25 € και 40  € 12%
από 40 € και 50  € 18%
ξεπερνά τα 50  € 20%
6. 

___

ΕΠΑΝΑΛΗΨΗ ΑΕΠΠ – ΠΡΟΒΛΗΜΑΤΑ ΣΥΜΠΛΗΡΩΜΑΤΙΚΑ

  • ΠΡΟΓΡΑΜΜΑ – «ΓΛΩΣΣΑ», ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ & ΕΝΤΟΛΕΣ 

    Δομή προγράμματος σε «ΓΛΩΣΣΑ» 

    Η δομή του προγράμματος στη «ΓΛΩΣΣΑ» είναι η παρακάτω:

    ΠΡΟΓΡΑΜΜΑ <όνομα προγράμματος> 

    ΣΤΑΘΕΡΕΣ 

    <δήλωση σταθερών>

    ΜΕΤΑΒΛΗΤΕΣ 

    <δήλωση μεταβλητών>

    ΑΡΧΗ 

    …. 

    …. <εντολές προγράμματος> 

    …. 

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ <όνομα προγράμματος> 

    Παρατηρήσεις: 

    Το όνομα του προγράμματος πρέπει να συμφωνεί με τους κανόνες δημιουργίας ονομάτων της «ΓΛΩΣΣΑΣ». 

    Οι δεσμευμένες, από τη «ΓΛΩΣΣΑ», λέξεις ΣΤΑΘΕΡΕΣ (για δήλωση σταθερών) ή/και ΜΕΤΑΛΗΤΕΣ (για δήλωση μεταβλητών) ενός προγράμματος χρησιμοποιούνται στην περίπτωση που στο πρόγραμμα υπάρχουν σταθερές ή/και μεταβλητές αντίστοιχα, αλλιώς παραλείπονται. 

    Οι δεσμευμένες λέξεις ΑΡΧΗ και ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ δηλώνουν αντίστοιχα την αρχή και το τέλος εκτέλεσης του προγράμματος. Μέσα σ’ αυτές τοποθετείται το κύριο μέρος του προ- γράμματος και περιλαμβάνει τις εκτελέσιμες εντολές. 

    Κάθε εντολή γράφεται σε ξεχωριστή γραμμή. 

    Αν μια εντολή χρειάζεται να συνεχιστεί στην επόμενη γραμμή, τότε ο πρώτος χαρακτήρας αυτής της γραμμής πρέπει να είναι ο χαρακτήρας «&».
    Αν ο πρώτος χαρακτήρας μιας εντολής είναι το θαυμαστικό « ! », τότε η γραμμή περιέχει σχόλια και όχι εκτελέσιμες εντολές. Δηλαδή, τη γραμμή αυτή την αγνοεί ο υπολογιστής κατά την εκτέλεση του προγράμματος. Τα σχόλια, μας βοηθούν να γράφουμε επεξηγήσεις σε διάφορα σημεία του προγράμματος. 

    * Από τη δομή του προγράμματος είναι εμφανές ότι για τη δημιουργία οποιουδήποτε προγράμματος σε «ΓΛΩΣΣΑ», είναι απαραίτητο να γνωρίζουμε τα βασικά στοιχεία της «ΓΛΩΣΣΑΣ» (αλφάβητο, τύπους δεδομένων, σταθερές, μεταβλητές και εντολές).

    Το αλφάβητο της «ΓΛΩΣΣΑΣ» 

    Το αλφάβητο της «ΓΛΩΣΣΑΣ» αποτελείται από:
    ΓΡΑΜΜΑΤΑ (Κεφαλαία ελληνικού αλφαβήτου, Πεζά ελληνικού αλφαβήτου, Κεφαλαία λατινικού αλφαβήτου, Πεζά λατινικού αλφαβήτου)
    ΨΗΦΙΑ (0,1,2,3,4,5,6,7,8,9)
    ΕΙΔΙΚΟΥΣ ΧΑΡΑΚΤΗΡΕΣ (+ , – , * , / , = , ( , ) , ! , & , το κενό) 

    1. Ποιες από τις παρακάτω εντολές είναι σωστές, ποιες είναι λάθος και γιατί; 

    1. αβ ← x1
    2. α+β ← x1
    3. α1 ← α+β
    4. α ← 3+2*6^2
    5. 2ψ ← ψ
    6. ΑΛΗΘΗΣ ← α
    7. Επώνυμο ← ΝΙΚΟΣ
    8. Επώνυμο ← ’ΝΙΚΟΣ’
    9. α*3 ← 2*α*β
    10. done ← ΨΕΥΔΗΣ
    11. α_ ← α1
    12. Β ← ’ΓΡΑΨΕ’
    13. x ← Όνομα
    14. z ← A>B
    15. z1 ← ’A>B’
    16. Α ← 3*(5+6^2)/2
    17. Προϊόν ← Ονομα_Προϊόντος
    18. Πρ ← ’Η/Υ’
    19. Σημαία ← 5>2*5
    20. Νίκος ← ’ΜΑΡΙΑ’ 

    Βασικές εντολές και απλά προγράμματα στη «ΓΛΩΣΣΑ» 

    Βασικές εντολές 

    Εντολή εκχώρησης
    Σύνταξη: Όνομα μεταβλητής ← <Έκφραση> 

    όπου <Έκφραση> = κάποια τιμή (ακέραια ή πραγματική ή χαρακτήρας ή λογική) ή κάποια άλλη μεταβλητή ή κάποια μαθηματική παράσταση.
    Τρόπος εκτέλεσης: Με την εντολή αυτή καταχωρίζεται στη μνήμη (στη μεταβλητή που έχουμε ορίσει στο αριστερό μέλος της σχέσης) η τιμή που δίνουμε ή που προκύπτει από πράξεις στο δεξί μέλος της σχέσης. 

    Παρατηρήσεις: 

    Σε μια εντολή εκχώρησης η μεταβλητή που βρίσκεται στο αριστερό μέρος αυτής δύναται να υπάρχει και στο δεξί μέρος της.
    Π.χ.
    1) α ← α+1 Αύξηση της μεταβλητής α κατά +1. Δηλαδή η νέα τιμή του α είναι η παλιά συν ένα 

    (μετρητής)
    2) α ← α+χ Αύξηση της μεταβλητής α κατά χ. Δηλαδή η νέα τιμή του σ είναι η παλιά συν τη τιμή της μεταβλητής χ (αθροιστής)
    Δεν επιτρέπεται στο αριστερό μέρος της εντολής εκχώρησης να υπάρχει πράξη ή μια οποιαδήποτε παράσταση ή τιμή. Το μόνο που επιτρέπεται είναι το όνομα_μεταβλητής.
    Η μεταβλητή και η έκφραση πρέπει να είναι του ίδιου τύπου. Δηλαδή, αν στο αριστερό μέρος έχουμε μεταβλητή που «παίρνει» ακέραιες τιμές, τότε το αποτέλεσμα της έκφρασης στο δεξί 

    μέρος της πρέπει να είναι ακέραια τιμή. 

    Ποιες από τις παρακάτω εντολές είναι σωστές, ποιες είναι λάθος και γιατί; 

    1. χ* χ ← α1

    2. χψ ← β

    3. ψ ← 5^2+3 

    4. α ← ’χ > 3’

    5. yx ← χ> 3

    6. χ+ψ β ← 5

    7. 3κ ← α + β

    8. 1χ ← χ+ψ

    9. α1 ← 5+x

    10. x ← ’Ψευδής’ 

    11. y ← Ψευδής

    12. Όνομα ← ΜΑΡΙΑ

    13. Όνομα ← ’ΜΑΡΙΑ’

    14. Τιμή ← ’12’

    15. Τιμή ← 12

    16. α ← 3 < 2 *5

    17. α&β ← α

    18. ΑΛΗΘΗΣ ← α

    19. χ ← 3 * 2^ 2+(10 – 6)^ 2 

    20. ΕΛΕΝΗ ← Χ + ψ 



    1. Ποιο από τα παρακάτω ονόματα μεταβλητών ή σταθερών, είναι σωστό ή λάθος και γιατί;

    1) α1
    6) 23χ
    11) α&
    16) ΑΛΗΘΗΣ

    2) Β_1
    7) 256
    12) ΠΡΟΓΡΑΜΜΑ
    17) Ψευδής1

    3) Β_
    8) χ+ψ
    13) Άννα

    4) 1_Φ
    9) χ/ψ
    14) Τιμή_Αγοράς

    5) χ23
    10) χ!1
    15) ‘ΜΑΡΙΑ’

    Κανόνες ονοματολογίας Μεταβλητών – Σταθερών

    Το όνομα μιας μεταβλητής ή σταθεράς μπορεί να αποτελείται:
    από γράμματα, πεζά ή κεφαλαία, του ελληνικού ή λατινικού αλφαβήτου από τα ψηφία 0, 1, 2, …, 9
    από σύμβολα μόνο την κάτω παύλα _

    Απαγορεύονται τα ακόλουθα:
    Ο πρώτος χαρακτήρας του ονόματος να είναι αριθμός
    Η ύπαρξη σημείων στίξεως ή ειδικών συμβόλων, όπως: +, -, /, [, ], &, # κ.λπ., εκτός από το σύμβολο της κάτω παύλας ( _ )
    Η χρήση δεσμευμένων λέξεων της «ΓΛΩΣΣΑΣ», όπως: οι λέξεις ΑΚΕΡΑΙΕΣ, ΧΑΡΑΚΤΗΡΕΣ κ.λπ.

    Στον παρακάτω πίνακα στην 1η στήλη δίνεται ο τύπος της μεταβλητής και στη 2η στήλη η τιμή μιας μεταβλητής. Να αντιστοιχιστούν οι τύποι των μεταβλητών της πρώτης στήλης, στις τιμές των μεταβλητών της δεύτερης στήλης.

    Τύπος μεταβλητής Τιμή μεταβλητής
    1. ΑΚΕΡΑΙΕΣ Α. Αληθής
    2. ΠΡΑΓΜΑΤΙΚΕΣ Β. 2345
    3. ΛΟΓΙΚΕΣ Γ. 56.9
    4. ΧΑΡΑΚΤΗΡΕΣ Δ. ‘ΑΛΗΘΗΣ’ 
    Ε. Ψευδής 
    Στ. ‘90.89’ 
    Ζ. -30,89
    Η.’Άννα’

     

    Τύποι δεδομένων 

    Η «ΓΛΩΣΣΑ» έχει τους εξής τέσσερις βασικούς τύπους δεδομένων, με τους οποίους καθορίζουμε τον τύπο της μεταβλητής ή σταθεράς που θα χρησιμοποιηθεί στο πρόγραμμα. 

    ΑΚΕΡΑΙΕΣ: Ο τύπος αυτός περιλαμβάνει όλους τους ακέραιους αριθμούς. Μπορεί να είναι θετι- κοί, αρνητικοί ή μηδέν.
    ΠΡΑΓΜΑΤΙΚΕΣ: Ο τύπος αυτός περιλαμβάνει όλους τους πραγματικούς αριθμούς. Μπορεί να είναι θετικοί, αρνητικοί ή μηδέν. 

    ΧΑΡΑΚΤΗΡΕΣ: Ο τύπος αυτός αναφέρεται τόσο σε ένα χαρακτήρα όσο και σε μια σειρά από χαρακτήρες. Οι χαρακτήρες πρέπει να βρίσκονται υποχρεωτικά μέσα σε εισαγωγικά. Επίσης, σαν χαρακτήρες μπορούμε να χρησιμοποιούμε και αριθμούς, γι’ αυτό τα στοιχεία αυτού του τύπου λέγονται και αλφαριθμητικά στοιχεία. Η διαφορά ενός αριθμού που είναι δηλωμένος σαν «Ακέραιος» ή «Πραγματικός», από τον αριθμό που είναι δηλωμένος σαν «Χαρακτήρας», είναι ότι ο πρώτος μπορεί να συμμετάσχει σε αριθμητικές πράξεις, ενώ ο δεύτερος δεν μπορεί. Παραδείγματα χαρακτήρων: ’Κ’, ’Μαρία’, ’Αύριο θα πάμε σινεμά’, ’123’, κλπ. 

    ΛΟΓΙΚΕΣ: Αυτός ο τύπος δέχεται μόνο δύο τιμές: ΑΛΗΘΗΣ και ΨΕΥΔΗΣ. 

    3. Δίνονται οι μεταβλητές με τις αντίστοιχες τιμές τους. Να γραφεί το τμήμα του προγράμματος που ορίζουμε τις μεταβλητές, δηλώνοντας τις παραπάνω στους αντίστοιχους τύπους τους.

    α  ←  10.89

    β ← ‘Πρόγραμμα’

    γ ← 275 

    δ  ←  ’Αληθής’

    x ← 45

    y ← Ψευδής 

    ζ  ←  ‘Νίκος’

    κ ← – 56

    λ ← -206.9

    ε ← ’– 4’ 

    Να γραφούν οι παρακάτω αριθμητικές εκφράσεις σε «ΓΛΩΣΣΑ», λαμβάνοντας υπόψη τη σειρά προτεραιότητας εκτέλεσης των πράξεων: 

    1) α+10

    2) 1/2α^3

    3) \( \cfrac {3χ +2ψ} {α–β} \)

    4) 2ημψ 

    5) 2+3χ + \( \cfrac{3} {ψ} \)

    6) \(  2 \cfrac{2χ+3}{2 * c} \)

    7) \( \cfrac{9}{8+x} \)

    8) χ+ψ

    9) |α|+ \( \cfrac{χ+9}{10} α \)

    10) \( \sqrt{α^2 + b2^2} \)

    Να γράψετε τις παρακάτω μαθηματικές εκφράσεις σε ΓΛΩΣΣΑ:

    \( \cfrac{x^2 + c^2}{2} \)

    \( 5β + \cfrac{2α + β^2}{α+β} \)

    \( \sqrt{χ + ψ} -\cfrac{4}{3 + χ} \)

    \( \cfrac{\sqrt{x}}{7} + 5 \)

    \( \sqrt{x + 5}{ψ} + |α + β| \)

    \( α^2 + \cfrac{3 + \sqrt{x}}{\sqrt{4 + ψ^2}} \)

    Να βρεθούν οι τιμές που δίνουν οι παρακάτω μαθηματικές εκφράσεις:

    α) (20 div 2)*2^2/2

    β) (Τ_Ρ(49) + 1) mod 3

    γ) Α_Μ(7/2) + 4^2

    δ) 20/2/4

    2. Να υπολογιστούν οι τιμές των παρακάτω αριθμητικών εκφράσεων:

    1. (3^2+T_P(9))/2

    2. A_T(10-5^2)+7

    3. 3 mod 2+5^2–2 div 3

    4. (3*2 div 2) mod 5

    5. T_P(3^2+4^2)/(2+1)

    6. 7/2+6

    7. (7+6)/2

    Αριθμητικές Εκφράσεις– Συγκριτικές – Λογικές Πράξεις 

    Τελεστές 

    Οι τελεστές είναι σύμβολα που χρησιμοποιούνται στις διάφορες πράξεις. Οι τελεστές διακρίνονται σε αριθμητικούς, συγκριτικούς και λογικούς. 

    Αριθμητικοί τελεστές 

    Οι αριθμητικοί τελεστές καλύπτουν τις βασικές πράξεις: πρόσθεση, αφαίρεση, πολλαπλασιασμό και διαίρεση, ενώ υποστηρίζεται η ύψωση σε δύναμη, η ακέραια διαίρεση και το υπόλοιπο της ακέραιας διαίρεσης.
    Οι τελεστές με τις αντίστοιχες πράξεις είναι: 

    Συναρτήσεις 

    Πολλές γνωστές συναρτήσεις από τα μαθηματικά χρησιμοποιούνται συχνά και περιέχονται στη «ΓΛΩΣΣΑ» και στον αλγόριθμο. 

    Για τη σύνταξη μιας αριθμητικής έκφρασης χρησιμοποιούνται αριθμητικοί τελεστές, μεταβλητές, σταθερές, συναρτήσεις και παρενθέσεις. 

    Οι αριθμητικές εκφράσεις υλοποιούν απλές ή σύνθετες μαθηματικές πράξεις.
    Κάθε αριθμητική έκφραση μας δίνει σαν αποτέλεσμα μια αριθμητική τιμή, που βρίσκεται μετά την εκτέλεση πράξεων. 

    Οι πράξεις σε μια αριθμητική έκφραση εκτελούνται με την παρακάτω ιεραρχία: 

    1. Ύψωση σε δύναμη (^)
    2. Πολλαπλασιασμός (*) και διαίρεση (/, DIV, MOD)
    3. Πρόσθεση (+) και αφαίρεση (-) 

    Σε περίπτωση που υπάρχει παρένθεση στην αριθμητική έκφραση, τότε εκτελούνται πρώτα οι πράξεις στη παρένθεση σύμφωνα με την παραπάνω ιεραρχία. 

    Όταν έχουμε πράξεις της ίδιας ιεραρχίας, π.χ. πολλαπλασιασμό και διαίρεση, τότε οι πράξεις εκτελούνται διαδοχικά από τα αριστερά προς τα δεξιά. 

     

    [/restrict]

    Να βρεθεί ποια από τις παρακάτω εκφράσεις είναι Αληθής ή Ψευδής, αν η μεταβλητή Κ έχει την τιμή 12, η μεταβλητή Λ την τιμή 6 και η μεταβλητή Μ την τιμή 2.

    (Όπου Α= Αληθής και Ψ= Ψευδής)

    α) Κ>Λ ΚΑΙ (Κ<Μ Ή Μ<=Λ) 

    β)Κ>ΛΚΑΙΚ<ΜΚΑΙ Μ<Λ

    γ)Κ=Λ+Μ+4 ΚΑΙ (Κ<Λ Ή Κ+Μ>Λ)

    δ)(Κ>ΛΚΑΙ Μ<Λ) Ή (Λ<>ΜΚΑΙΚ<Μ)

    Να βρεθούν οι τιμές των παρακάτω λογικών εκφράσεων, αν η μεταβλητή Α έχει τη τιμή 6, η μεταβλητή Β έχει τη τιμή -2 και η μεταβλητή Γ έχει τη τιμή 20. 

    (Α > 12 ΚΑΙ Β > -6) Ή (ΟΧΙ Α < 6 ΚΑΙ Β > 11) 

    ΟΧΙ (Α < 3 Ή Β > -1) 

    (ΟΧΙ Α > -2) ΚΑΙ (ΟΧΙ Β < -13) 

    (Α < 43 Ή Β > Γ) ΚΑΙ Α > Γ 

    ΟΧΙ (Α > Β ΚΑΙ Α > Γ) 

    ΟΧΙ (Α > Β) ΚΑΙ (Α > Γ)

    Συγκριτικοί τελεστές 

    Οι συγκριτικοί τελεστές είναι: 

    Οι συγκρίσεις σε μια μαθηματική έκφραση βοηθούν στη λήψη αποφάσεων, για παράδειγμα αν η ηλικία σου είναι μεγαλύτερη των 18 ετών τότε είσαι ενήλικος, διαφορετικά δεν είσαι ενήλικος. 

    Λογικοί τελεστές 

    Σε πολλά προβλήματα οι επιλογές δεν αρκεί να γίνονται με απλές λογικές παραστάσεις, δηλαδή με μια απλή σύγκριση, αλλά χρειάζεται να συνδυαστούν μια ή περισσότερες λογικές εκφράσεις. Οι λογικές εκφράσεις αποτελούνται από συγκριτικές πράξεις. Αυτό επιτυγχάνεται με τη χρήση τριών βασικών λογικών τελεστών: ΟΧΙ, ΚΑΙ και Ή. Οι λογικές παραστάσεις αποτελούνται από λογικές μεταβλητές, οι οποίες «παίρνουν» μια λογική τιμή, ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ. Το αποτέλεσμα που επιστρέφει μια λογική έκφραση είναι μια λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, ανάλογα με τις τιμές των μεταβλητών της. 

    Στον παρακάτω πίνακα δίνονται τις τιμές των τριών αυτών λογικών πράξεων για όλους τους συνδυα- σμούς τιμών των μεταβλητών τους Α, Β: 

    Οι πράξεις σε μια λογική έκφραση εκτελούνται με την παρακάτω ιεραρχία:

    1. ΟΧΙ   2. ΚΑΙ   3. Ή 

    Σε περίπτωση που υπάρχει παρένθεση στη λογική έκφραση, τότε εκτελούνται πρώτα οι πράξεις στην παρένθεση σύμφωνα με την παραπάνω ιεραρχία.
    Στη περίπτωση που σε μια έκφραση συνυπάρχουν περισσότερα από ένα είδη πράξεων, τότε η ιεραρ- χία των πράξεων είναι η εξής: 

    1. Αριθμητικοί τελεστές

    2. Συγκριτικοί τελεστές και

    3. Λογικοί τελεστές. 

     

    Ποια είναι η τελική τιμή της μεταβλητής α, όταν εκτελεστούν οι παρακάτω εντολές, αν σαν είσοδο δεδομένων από το πληκτρολόγιο δώσουμε τις τιμές 5, 10 και 25. 

    ΔΙΑΒΑΣΕ α

    β ← 2^3+α 

    ΔΙΑΒΑΣΕ γ,β 

    α ← β+γ+α 

    Δίνεται το παρακάτω τμήμα προγράμματος: 

    α←3 

    χ ← 10 * α

    έλεγχος ← Αληθής

    ψ ← χ<α

    έλεγχος ← έλεγχος ΚΑΙ ψ 

    α ← α +χ 

    Να γίνει ο πίνακας τιμών. 

    Λύση 

    Εντολές α χ έλεγχος ψ
    α←3 3
    χ ← 10 * α 30
    έλεγχος ← Αληθής Αληθής 
    ψ ← χ<α Ψευδής 
    έλεγχος ← έλεγχος ΚΑΙ ψ Ψευδής 
    α ← α +χ 33

    Τι εμφανίζει το παρακάτω τμήμα προγράμματος; 

    α ← 3^2 

    ΓΡΑΨΕ ‘α =’, α 

    β ← 5

    ΓΡΑΨΕ ‘β=’, β 

    γ ← α*β 

    ΓΡΑΨΕ ‘α*β= ‘, γ 

    Τι εμφανίζουν τα παρακάτω προγράμματα για τιμές εισόδου 12 και 7;

    ΠΡΟΓΡΑΜΜΑ Πρόγραμμα1 

    ΜΕΤΑΒΛΗΤΕΣ 

    ΑΚΕΡΑΙΕΣ: γ, δ, χ, ψ 

    ΑΡΧΗ 

    ΓΡΑΨΕ ‘Δώσε 2 ακέραιες τιμές τιμές’ 

    ΔΙΑΒΑΣΕ χ, ψ

    γ ← χ div ψ

    δ ← χ mod ψ 

    ΓΡΑΨΕ ‘χ=’, χ, ‘ ψ=’, ψ 

    ΓΡΑΨΕ ‘Υπόλοιπο=’, δ

    ΓΡΑΨΕ ‘Πηλίκο=’, γ 

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πρόγραμμα1

    ΠΡΟΓΡΑΜΜΑ Πρόγραμμα2

    ΜΕΤΑΒΛΗΤΕΣ 

    ΑΚΕΡΑΙΕΣ: x,y 

    ΑΡΧΗ 

    ΓΡΑΨΕ ‘Δώσε το x’ 

    ΔΙΑΒΑΣΕ x

    ΓΡΑΨΕ ‘Δώσε το y’ 

    ΔΙΑΒΑΣΕ y 

    x ← 3 ^ 2+10 div 2^2 

    y ← 5+2 ^2 * 2+7 div 2 

    ΓΡΑΨΕ ‘Νέα τιμή x =’,x 

    ΓΡΑΨΕ ‘Νέα τιμή y =’,y 

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πρόγραμμα2

    Να δημιουργήσετε τον πίνακα τιμών των μεταβλητών του προγράμματος Α1.

    ΠΡΟΓΡΑΜΜΑ Α1 

    ΜΕΤΑΒΛΗΤΕΣ 

    ΑΚΕΡΑΙΕΣ: Α, Β, Γ, χ, ψ 

    ΑΡΧΗ 

    χ ← 100
    ψ ← 200
    Α ← χ + 1
    Β ← 3* χ
    Γ ← Α + Β

    ΑΝ Γ > 400 ΤΟΤΕ 

    Α ← Β 

    Β ← χ 

    ΑΛΛΙΩΣ 

    ΑΝ Β > 200 ΤΟΤΕ 

    Β ← Α 

    Α ← 20 

    ΑΛΛΙΩΣ 

    Α ← Γ 

    Β ← Α 

    ΤΕΛΟΣ_ΑΝ 

    ΤΕΛΟΣ_ΑΝ 

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α1

    Τι θα εμφανίσουν τα παρακάτω προγράμματα αν σαν είσοδο δοθούν οι τιμές 5 και 10, στις μεταβλητές χ και ψ αντίστοιχα;

    ΠΡΟΓΡΑΜΜΑ Π1 

    ΜΕΤΑΒΛΗΤΕΣ 

    ΑΚΕΡΑΙΕΣ: χ, ψ 

    ΑΡΧΗ 

    ΓΡΑΨΕ ‘Δώσε τιμή για χ και ψ:’ 

    ΔΙΑΒΑΣΕ χ, ψ

    χ ← χ div 2

    ψ ← ψ mod 3

    ΑΝ χ = ψ τότε

    χ ← χ^ 2 + 1

    ψ ←  2* ψ – 4^ 2 

    ΑΛΛΙΩΣ 

    χ ← χ mod 2

    ψ ← ψ div 3 

    ΤΕΛΟΣ_ΑΝ 

    ΓΡΑΨΕ ‘χ =’, χ, ‘ ψ=’, ψ 

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Π1

    ΠΡΟΓΡΑΜΜΑ Π2 ΜΕΤΑΒΛΗΤΕΣ 

    ΑΚΕΡΑΙΕΣ: χ, ψ 

    ΛΟΓΙΚΕΣ: f 

    ΑΡΧΗ 

    ΓΡΑΨΕ ‘Δώσε 2 ακέραιες τιμές:’ 

    ΔΙΑΒΑΣΕ χ, ψ

    χ ← χ^ 2 + 1

    ψ ← 2* ψ + χ^ 2 

    f ← (χ mod 2 = 0) ΚΑΙ (ψ mod 2 = 0) 

    ΑΝ f = ΑΛΗΘΗΣ ΤΟΤΕ 

    ΓΡΑΨΕ ‘Άρτιοι:’, χ, ψ 

    ΤΕΛΟΣ_ΑΝ 

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Π2

    3. ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ 

    3.6 Μετατροπές από μία δομή επανάληψης σε άλλη 

    1. Μετατροπή από «ΟΣΟ…ΕΠΑΝΑΛΑΒΕ» σε ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ…ΜΕΧΡΙΣ_ΟΤΟΥ» 

    ΔΙΑΒΑΣΕ x

    ΟΣΟ x<>0 ΕΠΑΝΑΛΑΒΕ 

    y ← x ^ 2 

    ΓΡΑΨΕ y 

    ΔΙΑΒΑΣΕ x 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    2. Μετατροπή από «ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ…ΜΕΧΡΙΣ_ΟΤΟΥ» σε «ΟΣΟ…ΕΠΑΝΑΛΑΒΕ» 

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 

    ΔΙΑΒΑΣΕ x

    y <-x ^ 2 

    ΓΡΑΨΕ y 

    ΜΕΧΡΙΣ_ΟΤΟΥ x = 0 

    Μετατροπή από «ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ…» σε «ΟΣΟ…ΕΠΑΝΑΛΑΒΕ» και αντιστρόφως 

    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 

    ΓΡΑΨΕ i^3 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΙΑ i ΑΠΟ 10 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 2 

    ΓΡΑΨΕ i ^ 2 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    ΓΙΑ i ΑΠΟ 1000 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ -1

    ΓΡΑΨΕ i 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    2. Μετατροπή από «ΟΣΟ…ΕΠΑΝΑΛΑΒΕ» σε «ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ…» 

    i <- 10

    ΟΣΟ i <= 100 ΕΠΑΝΑΛΑΒΕ 

    ΓΡΑΨΕ i 

    i <- i+1 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    i <-100

    ΟΣΟ i >=1 ΕΠΑΝΑΛΑΒΕ 

    ΓΡΑΨΕ i 

    i <- i – 2 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    1. Πόσες φορές θα εκτελεστούν οι παρακάτω βρόχοι επανάληψης; 

    1) ΓΙΑ i ΑΠΟ -3 ΜΕΧΡΙ 1

    2) ΓΙΑ i ΑΠΟ 4 ΜΕΧΡΙ 2

    3) ΓΙΑ i ΑΠΟ 5 ΜΕΧΡΙ 5 

    4) ΓΙΑ i ΑΠΟ 6 ΜΕΧΡΙ 6 ΜΕ_ΒΗΜΑ 0

    5) ΓΙΑ i ΑΠΟ -9 ΜΕΧΡΙ -15 ΜΕ_ΒΗΜΑ -1 

    6) ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΜΕ_ΒΗΜΑ 2 

    7) ΓΙΑ i ΑΠΟ -4 ΜΕΧΡΙ -1 ΜΕ_ΒΗΜΑ -2 

    8) ΓΙΑ i ΑΠΟ 5 ΜΕΧΡΙ 12 ΜΕ_ΒΗΜΑ 3 

    9) ΓΙΑ i ΑΠΟ 0.5 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ 0.5 

    10) ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ 0 

    2. Πόσες φορές θα εκτελεστούν οι παρακάτω βρόχοι; 

    1) 

    α←0
    ΟΣΟ α<15 ΕΠΑΝΑΛΑΒΕ 

    χ←α+1 

    α←α+3 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    3) 

    α←10
    ΟΣΟ α>=20 ΕΠΑΝΑΛΑΒΕ 

    ΓΡΑΨΕ α 

    α←α+5 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    2) 

    α← -12
    ΟΣΟ α>0 ΕΠΑΝΑΛΑΒΕ 

    ΓΡΑΨΕ α 

    α←α+3 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    4) 

    α←2
    ΟΣΟ α<=11 ΕΠΑΝΑΛΑΒΕ 

    ΓΡΑΨΕ α 

    α←α+5 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    3. Πόσες φορές θα εκτελεστούν οι παρακάτω βρόχοι; 

    1. β←0 

    ………….

    Να συμπληρωθεί

    2) 

    4) 

    4. Δίνεται το παρακάτω τμήμα προγράμματος σε «ΓΛΩΣΣΑ»: 

    sum ← 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6 ΜΕ_ΒΗΜΑ 2 

    sum ← sum+i

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    i) Να μετατραπεί σε ισοδύναμο με χρήση της δομής ΟΣΟ…ΕΠΑΝΑΛΑΒΕ
    ii) Να μετατραπεί σε ισοδύναμο με χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ… ΜΕΧΡΙΣ_ΟΤΟΥ 

    5. Δίνεται το παρακάτω τμήμα προγράμματος σε «ΓΛΩΣΣΑ»:

    sum ←0 

    i ←0

    ΔΙΑΒΑΣΕ α

    ΟΣΟ i<=5 ΕΠΑΝΑΛΑΒΕ 

    sum ← sum+α 

    i ←i+1 

    ΔΙΑΒΑΣΕ α 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    i) Να μετατραπεί σε ισοδύναμο με χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ…ΜΕΧΡΙΣ_ΟΤΟΥ ii) Να μετατραπεί σε ισοδύναμο με χρήση της δομής ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ 

    6. Δίνεται το παρακάτω τμήμα προγράμματος σε «ΓΛΩΣΣΑ»:

    sum ← 10 

    ΔΙΑΒΑΣΕ x 

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 

    sum ← sum+x 

    ΔΙΑΒΑΣΕ x 

    ΜΕΧΡΙΣ_ΟΤΟΥ x<=0 

    Να μετατραπεί σε ισοδύναμο με χρήση της δομής ΟΣΟ… ΕΠΑΝΑΛΑΒΕ και της δομής ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ 

    7. Τι εμφανίζεται στην οθόνη κατά την εκτέλεση του παρακάτω προγράμματος σε «ΓΛΩΣΣΑ»; Να συμπληρωθεί ο πίνακας τιμών. 

    ΠΡΟΓΡΑΜΜΑ Ασκηση_Επανάληψης 

    ΜΕΤΑΒΛΗΤΕΣ 

    ΑΚΕΡΑΙΕΣ: α, β, i, j 

    ΑΡΧΗ 

    α <- 10

    β <- 5

    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ_ΒΗΜΑ 5 

    ΓΙΑ j ΑΠΟ i ΜΕΧΡΙ 15 ΜΕ_ΒΗΜΑ 2 

    α <- α div 2

    β <- β mod 3

    ΑΝ α <> 0 ΤΟΤΕ 

    ΓΡΑΨΕ α 

    ΤΕΛΟΣ_ΑΝ 

    ΑΝ β <> 0 ΤΟΤΕ 

    ΓΡΑΨΕ β 

    ΤΕΛΟΣ_ΑΝ 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ασκηση_Επανάληψης 

  • Πρόβλημα Α.1

    Σε μια εταιρεία οι αποδοχές ενός υπαλλήλου καθορίζονται από το βασικό μισθό, τα επιδόματα και τις κρατήσεις. 

    – Ο βασικός μισθός είναι 537€. Το επίδομα για κάθε υπάλληλο είναι 12€ για κάθε χρόνο εργασίας. 

    – Οι κρατήσεις είναι 15% για φόρο επί του βασικού μισθού και 2% για χαρτόσημο επί του βασικού μισθού. 

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το όνομα του υπαλλήλου και τα χρόνια υπηρεσίας του στην εταιρεία. Στη συνέχεια να υπολογίζει το επίδομα και τις κρατήσεις του και τέλος να εμφανίζει το βασικό μισθό, το επίδομα, τις κρατήσεις κάθε μια χωριστά και το μισθό που του καταβάλλεται. 

    Πρόβλημα Α.2

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το πλήθος των άτοκων δόσεων που επιθυμεί να πληρώσει ένας πελάτης για κάποια αγορά του και το ποσό της αγοράς. Να υπολογίζει και να εμφανίζει με κατάλληλο μήνυμα το ποσό της κάθε δόσης. 

    Πρόβλημα Α.3

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει έναν τριψήφιο αριθμό. Να υπολογίζει και να εμφανίζει το άθροισμα των ψηφίων του. 

    Πρόβλημα Α.4

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το κεφάλαιο που κατατέθηκε σε κάποια τράπεζα με επιτόκιο 1,6%. Να υπολογίζει και να εμφανίζει τον τόκο που θα εισπράξουμε μετά από 3 χρόνια. 

    Πρόβλημα Α.5

    Ένας υπάλληλος σε μια εταιρεία, επιπλέον του βασικού μισθού του, παίρνει επίδομα 20€ για κάθε παιδί και 30€ επίδομα γάμου, ενώ έχει κρατήσεις 15% στο βασικό μισθό του. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», που να διαβάζει τον βασικό μισθό του υπαλλήλου, και τον αριθμό των παιδιών του (θεωρούμε ότι ο υπάλληλος είναι παντρεμένος). Να υπολογίζει και να εμφανίζει τον τελικό μισθό του, τυπώνοντας κατάλληλο μήνυμα. 

  • Πρόβλημα Β.1

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει την ακτίνα ενός κύκλου και να εμφανίζει το εμβαδόν του κύκλου. Θεωρήστε ότι η ακτίνα είναι θετικός αριθμός.

    Πρόβλημα Β.2

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει έναν ακέραιο αριθμό και να εμφανίζει την απόλυτη τιμή του.

    Πρόβλημα Β.3

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει την ακτίνα κύκλου και και αν αυτή είναι θετικός αριθμός τότε να υπολογίζει και να τυπώνεται το εμβαδόν του κύκλου.

    Πρόβλημα Β.4

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει έναν ακέραιο αριθμό και να εμφανίζει το διπλάσιό του αν το τελευταίο ψηφίο του αριθμού είναι 2 ή 5, ενώ σε διαφορετική περίπτωση, να υπολογίζει και να εμφανίζει το τριπλάσιό του.

    Πρόβλημα Β.5

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει δύο ακέραιους αριθμούς. Αν είναι και οι δύο άρτιοι ή και οι δύο περιττοί, τότε να εμφανίζει το γινόμενό τους, αλλιώς να εμφανίζει την απόλυτη τιμή της διαφορά τους. 

    Πρόβλημα Β.6

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το πλήθος των υπολογιστών που αγοράζονται από κάποιο κατάστημα. Η τιμή αγοράς των υπολογιστών εξαρτάται από το πλήθος των υπολογιστών που αγοράζονται, σύμφωνα με τον παρακάτω πίνακα: 

    Πλήθος Τιμή ανά τεμάχιο
    1 μέχρι 10 500 €
    11 μέχρι 20 450 €
    21 μέχρι 50 360 €
    51 και πάνω 210 €

    Τέλος, να υπολογίζει και να εμφανίζει τη συνολική αξία των υπολογιστών που αγοράστηκαν. 

    Πρόβλημα Β.7

    2. Μια εταιρεία κινητής τηλεφωνίας ακολουθεί ανά μήνα την εξής πολιτική τιμών: 

    Πάγιο 20€
    Χρόνος ομιλίας σε δευτερ. Χρονοχρέωση (€/δευτερ.)
    1 – 300  0.50
    301 – 1000 0.45
    1001 και άνω 0.30

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ» το οποίο:

    α) Να διαβάζει τη χρονική διάρκεια σε δευτερόλεπτα των τηλεφωνημάτων ενός συνδρομητή σε διάστημα ενός μήνα.

    β) Να υπολογίζει τη μηνιαία χρέωση του συνδρομητή.

    γ) Να εμφανίζει κατάλληλο μήνυμα με τη μηνιαία χρέωση του συνδρομητή. 

    Θεωρήστε ότι ο χρόνος είναι πάντα θετικός αριθμός. 

    Πρόβλημα Β.8

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τρεις πραγματικούς αριθμούς.
    Αν το άθροισμά τους είναι μεγαλύτερο του 10, να υπολογίζει και να εμφανίζει το μέσο όρο τους. Διαφορετικά να βρίσκει τον μεγαλύτερο απ’ αυτούς και να τον εμφανίζει με κατάλληλο μήνυμα. 

    Πρόβλημα Β.9

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να υπολογίζει τον μισθό ενός εργαζόμενου σε μια εταιρεία που εργάζεται με την ώρα.
    Να διαβάζει το όνομά του, τις ώρες εργασίας του για τον συγκεκριμένο μήνα, το ποσό που πληρώνεται για την κάθε ώρα καθώς και το αν είναι έγγαμος. 

    Οι κρατήσεις που του γίνονται εξαρτώνται από το ύψος του μισθού ως εξής:
    Αν ο μισθός του είναι μέχρι 1000 € τον μήνα έχει 15% κρατήσεις, ενώ διαφορετικά έχει 20% κρατήσεις. Επίσης, αν είναι έγγαμος έχει ένα επίδομα 50 €.
    Τέλος, να υπολογίζει και να τυπώνει τον τελικό μισθό που λαμβάνει ο υπάλληλος, όπως επίσης να τυπώνει και όλες τις κρατήσεις και τα επιδόματα που του αντιστοιχούν. 

    Πρόβλημα Β.10

    3. Σ’ ένα σχολείο ένας μαθητής μπορεί να κάνει 60 δικαιολογημένες απουσίες και 55 αδικαιολόγητες, ενώ όσες δικαιολογημένες απουσίες κάνει πέρα των 60 θεωρούνται αδικαιολόγητες.
    Αν ο μαθητής κάνει πάνω από 55 αδικαιολόγητες απουσίες, τότε δίνει όλα τα μαθήματα τον Σεπτέμβριο. Αν ο μαθητής κάνει πάνω από 140 αδικαιολόγητες απουσίες, τότε επαναλαμβάνει την τάξη. 

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τις δικαιολογημένες και τις αδικαιολόγητες απουσίες ενός μαθητή και ανάλογα με το πλήθος τους να τυπώνει ένα από τα παρακάτω μηνύματα:
    – ’Ολική τον Σεπτέμβρη’ ή 

    – ’Επανάληψη τάξης’ ή 

    – ’Προβιβασμός’. 

    Πρόβλημα Β.11

    Σε μια εξεταστική διαδικασία κάθε γραπτό αξιολογείται αρχικά από δύο βαθμολογητές και υπάρχει περίπτωση το γραπτό να χρειάζεται αναβαθμολόγηση από τρίτο βαθμολογητή. Στην περίπτωση αναβαθμολόγησης ο τελικός βαθμός υπολογίζεται ως εξής: 

    Αν ο βαθμός του τρίτου βαθμολογητή είναι ίσος με τον μέσο όρο (Μ.Ο.) των βαθμών των δύο πρώτων βαθμολογητών, τότε ο τελικός βαθμός είναι ο Μ.Ο. 

    Αν ο βαθμός του τρίτου βαθμολογητή είναι μικρότερος από το μικρότερο βαθμό ΜΙΝ των δύο πρώτων βαθμολογητών, τότε ο τελικός βαθμός είναι ο ΜΙΝ. 

    Διαφορετικά, ο τελικός βαθμός είναι ο μέσος όρος του βαθμού του τρίτου βαθμολογητή με τον πλησιέστερο προς αυτόν βαθμό των δύο πρώτων βαθμολογητών. 

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να υπολογίζει τον τελικό βαθμό ενός γραπτού με αναβαθμολόγηση ως εξής: 

    1)  να διαβάζει τους βαθμούς του πρώτου, του δεύτερου και του τρίτου βαθμολογητή ενός γραπτού, 

    2)  να υπολογίζει και να εμφανίζει τον μεγαλύτερο (ΜΑΧ) και τον μικρότερο (ΜΙΝ) από τους βαθμούς του πρώτου και του δεύτερου βαθμολογητή, και 

    3)  να υπολογίζει και να εμφανίζει τον τελικό βαθμό του γραπτού, σύμφωνα με την παραπάνω διαδικασία. 

    Θεωρήστε ότι και οι τρεις βαθμοί είναι θετικοί ακέραιοι αριθμοί και δεν απαιτείται έλεγχος των δεδομένων. 

    Πρόβλημα Β.12

    Μια εταιρεία ταχυδρομικών υπηρεσιών εφαρμόζει για τα έξοδα αποστολής ταχυδρομικών επιστολών εσωτερικού και εξωτερικού, χρέωση σύμφωνα με τον παρακάτω πίνακα: 

    Βάρος επιστολής σε γρ. Χρέωση εσωτερικού σε € Χρέωση εξωτερικού σε €
    Από 0 έως και 500 2 4.8
    Από 500 έως και 1000 3.50 7.20 
    Από 1000 έως και 2000 4.60 11.50

    Για παράδειγμα, τα έξοδα αποστολής μιας επιστολής βάρους 800 γραμμαρίων και προορισμού εσωτερικού είναι 3,5 €.
    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο: 

    1. Να διαβάζει το βάρος της επιστολής.
    2. Να διαβάζει τον προορισμό της επιστολής. H τιμή ’EΣ’ δηλώνει προορισμό εσωτερικού και η τιμή ’ΕΞ’ δηλώνει προορισμό εξωτερικού.
    3. Να υπολογίζει τα έξοδα αποστολής ανάλογα με τον προορισμό και το βάρος της επιστολής. 

    Πρόβλημα Β.13

    Μια δημοτική αρχή ακολουθεί την εξής τιμολογιακή πολιτική για την κατανάλωση νερού ανά μήνα: Χρεώνει πάγιο ποσό 12€ και εφαρμόζει κλιμακωτή χρέωση σύμφωνα με τον παρακάτω πίνακα: 

    Κατανάλωση νερού σε κυβικά Χρέωση ανά κυβικό
    Από 0 έως και 5 δωρεάν
    Από 5 έως και 10 0,5 €
    Από 10 έως και 20 0,7 €
    Από 20 και άνω 1,00 €

    Στο ποσό που προκύπτει από την αξία του νερού και το πάγιο, υπολογίζεται ο ΦΠΑ με συντελεστή 23%. Το τελικό ποσό προκύπτει από το άθροισμα της αξίας του νερού, το πάγιο, το ΦΠΑ και το δημοτικό φόρο που είναι 10€.
    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο: 

    1. Να διαβάζει τη μηνιαία κατανάλωση του νερού. (Θεωρήστε ότι η μηνιαία κατανάλωση νερού είναι μη αρνητικός αριθμός).
    2. Να υπολογίζει την αξία του νερού που καταναλώθηκε, σύμφωνα με την παραπάνω τιμολογιακή πολιτική.
    3. Να υπολογίζει τον ΦΠΑ.
    4. Να υπολογίζει και να εμφανίζει το τελικό ποσό πληρωμής.

    Πρόβλημα Β.14

    Στο τέλος κάθε έτους οι ιδιοκτήτες των αυτοκινήτων προπληρώνουν τα Τέλη Κυκλοφορίας για την επόμενη χρονιά, σύμφωνα με τον κυβισμό των αυτοκινήτων. Το ποσό που αναλογεί για το κάθε αυτοκίνητο ανάλογα με τον κυβισμό του, φαίνεται στον παρακάτω πίνακα: 

    Κυβισμός Τέλη Κυκλοφορίας
    Έως 300 22 €
    301 – 785 55 €
    786 – 1.071 120 €
    1.072 – 1.357 135 €
    1.358 – 1.548 255 €
    1.549 – 1.738 280 €
    1.739 – 1.928 320 €
    1.929 – 2.357 690 €
    2.358 – 3.000 920 €
    3.001 – 4.000 1.150 €
    άνω των 4.000 1.380 €

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τον κυβισμό ενός αυτοκινήτου και να υπολογίζει και να τυπώνει τον φόρο που του αναλογεί. 

    Πρόβλημα Β.15

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει από το πληκτρολόγιο τρεις διαφορετικούς ακέραιους αριθμούς και στη συνέχεια να τυπώνει τον αριθμό που η αξία του είναι ανάμεσα στον μεγαλύτερο και στον μικρότερο από αυτούς (δηλαδή, αν δοθούν οι αριθμοί 107, 53, 42 τότε θα εμφανιστεί ο 53, διότι 107 > 53 > 42 ή 42 < 53 < 107). 

    Πρόβλημα Β.16

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το όνομα ενός υπαλλήλου, τις ώρες εργασίας και το ωρομίσθιο του. Οι κρατήσεις που γίνονται στον υπάλληλο είναι 15%, αν ο μισθός του είναι μέχρι 1.000 €, διαφορετικά είναι 20%. Σε περίπτωση που ο υπάλληλος έχει λιγότερες από 15 ώρες εργασίας τότε οι παραπάνω κρατήσεις μειώνονται κατά 2%. 

    Υπόδειξη: Ο μισθός κάθε υπαλλήλου υπολογίζεται από τον τύπο:
    Ώρες x Ωρομίσθιο – Κρατήσεις
    Και οι κρατήσεις από τον τύπο:
    Κρατήσεις = (Ώρες x Ωρομίσθιο) x Ποσοστό/100 

    Πρόβλημα Β.17

    Σε ένα σχολείο η φοίτηση ενός μαθητή χαρακτηρίζεται ως επαρκής, εάν το σύνολο όλων των απουσιών του δεν ξεπερνά τις 100, εκ των οποίων οι 60 είναι δικαιολογημένες ή το σύνολο των απουσιών του δεν ξεπερνά τις 160 και οι 120 είναι δικαιολογημένες και ο Μέσος όρος βαθμολογίας του μαθητή μεγαλύτερος του 15. Διαφορετικά η φοίτηση χαρακτηρίζεται ως ανεπαρκής. 

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο:
    1) Να διαβάζει από το πληκτρολόγιο τον Μέσο Όρο του μαθητή, το σύνολο των Δικαιολογημένων και το σύνολο των Αδικαιολόγητων απουσιών του.
    2) Να εμφανίζει το μήνυμα ’Φοίτηση επαρκής’ ή ’Φοίτηση ανεπαρκής’, ανάλογα με τις απουσίες του. 

    Πρόβλημα Β.18

    Το Υπουργείο Οικονομικών φορολογεί τους Ελεύθερους Επαγγελματίες σύμφωνα με τον παρακάτω πίνακα: 

    Από 1€ μέχρι 20.000€ 22%
    Από 20.001€ μέχρι 30.000€ 29%
    Από 30.001€ μέχρι 40.000€ 37%
    Από 40.001€ και άνω 45%

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το εισόδημα ενός ελεύθερου επαγγελματία και στη συνέχεια να υπολογίζει και να εμφανίζει τον φόρο που του αναλογεί. Ο υπολογισμός φόρου γίνεται κλιμακωτά, σύμφωνα με τον παραπάνω πίνακα. 

    Πρόβλημα Β.19

    Με το σύστημα πληρωμής των διοδίων, οι οδηγοί των τροχοφόρων έχουν τη δυνατότητα να πληρώνουν το αντίτιμο των διοδίων με ειδική μαγνητική κάρτα. Υποθέστε ότι υπάρχει μηχάνημα το οποίο διαθέτει είσοδο για την κάρτα και φωτοκύτταρο. Το μηχάνημα διαβάζει από την κάρτα το υπόλοιπο των χρημάτων και το αποθηκεύει σε μια μεταβλητή Υ και με το φωτοκύτταρο αναγνωρίζει τον τύπο του τροχοφόρου και το αποθηκεύει σε μια μεταβλητή Τ. Υπάρχουν τρεις τύποι τροχοφόρων: δίκυκλα (Δ), επιβατικά (Ε) και φορτηγά (Φ), με αντίτιμο διοδίων 1.20€, 2.40€ και 3.50€ αντίστοιχα. 

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο:
    1) Να ελέγχει τον τύπο του τροχοφόρου και να εκχωρεί στη μεταβλητή Α το αντίτιμο των διοδίων, ανάλογα με τον τύπο του τροχοφόρου.
    2) Να ελέγχει την πληρωμή των διοδίων με τον παρακάτω τρόπο:
    Αν το υπόλοιπο της κάρτας επαρκεί για την πληρωμή του αντιτίμου των διοδίων, αφαιρεί το ποσό αυτό από την κάρτα.
    Αν η κάρτα δεν έχει υπόλοιπο, το μηχάνημα ειδοποιεί με μήνυμα για το ποσό που πρέπει να πληρωθεί.
    Αν το υπόλοιπο δεν επαρκεί, μηδενίζεται η κάρτα και δίνεται με μήνυμα το ποσό που απομένει να πληρωθεί. 

    Πρόβλημα Β.20

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να δέχεται από το πληκτρολόγιο έναν ακέραιο αριθμό και να ελέγχει εάν είναι διψήφιος και θετικός. Στην περίπτωση που ισχύει, να τυπώνεται το μήνυμα «Θετικός, Διψήφιος αριθμός», ενώ διαφορετικά να τυπώνονται για κάθε περίπτωση «Μόνο θετικός» ή «Μόνο διψήφιος» ή «Ούτε θετικός, ούτε διψήφιος».

    Πρόβλημα Β.21

    Ένα μαγαζί με ηλεκτρονικά παιχνίδια χρεώνει τους πελάτες του κλιμακωτά, ανάλογα με το πόση ώρα χρησιμοποιούν τα παιχνίδια, σύμφωνα με τον παρακάτω πίνακα: 

    Χρόνος σε λεπτά Χρέωση ανά λεπτό
    1-60 0,15 €
    61-90 0,22 €
    91-120 0,37 €
    121-180 0,42 €
    >180 0,55 €

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τον χρόνο χρήσης του ηλεκτρονικού παιχνιδιού και στη συνέχεια να υπολογίζει και να εμφανίζει το ποσό χρέωσης, σύμφωνα με τον παραπάνω πίνακα.

    Πρόβλημα Β.22

    Ένα ταξιδιωτικό γραφείο οργανώνει 3ήμερες και 5ήμερες εκδρομές στην Κρήτη, Ρόδο και Μύκονο με αεροπλάνο ή πλοίο. Οι τιμές κατ’ άτομο για κάθε περίπτωση, βρίσκονται στον παρακάτω πίνακα. 

    Αεροπλάνο Πλοίο
    Προορισμός 3ήμερη 5ήμερη 3ήμερη 5ήμερη
    Κρήτη 400 € 600 € 550 € 750 €
    Ρόδος 500 € 700 € 700 € 900 €
    Μύκονος 550 € 650 € 650 € 850 €

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τον προορισμό, το μέσο μεταφοράς (Π = πλοίο ή Α = Αεροπλάνο), τις ημέρες διαμονής (3 ή 5) και το πλήθος των ατόμων. Στη συνέχεια να υπολογίζει και τυπώνει το κόστος της εκδρομής. 

  • Πρόβλημα Γ.1

    Να γραφεί πρόγραμμα το οποίο δέχεται από το πληκτρολόγιο θετικούς αριθμούς. Η πληκτρολόγηση σταματά με την πληκτρολόγηση αρνητικού αριθμού ή του 0. Τέλος, τυπώνει το άθροισμα των θετικών αριθμών που έχουν πληκτρολογηθεί.

    Πρόβλημα Γ.2

    Να γραφεί πρόγραμμα το οποίο θα δέχεται από το πληκτρολόγιο τον μέσο προφορικό βαθμό και τον γραπτό βαθμό ενός μαθητή και θα υπολογίζει και θα τυπώνει τον μέσο όρο των βαθμών του μαθητή. Κατά την πληκτρολόγηση να γίνεται έλεγχος των βαθμών που πληκτρολογούνται, ώστε να βρίσκονται στο διάστημα [0-20].

    Πρόβλημα Γ.3

    Να γραφεί πρόγραμμα το οποίο να δέχεται από το πληκτρολόγιο δύο ακέραιους αριθμούς και στη συνέχεια να επιλέγεται η πράξη που πρόκειται να εκτελεστεί για τους παραπάνω αριθμούς, σύμφωνα με το μενού (επιλογής):

    1. Πρόσθεση
    2. Αφαίρεση
    3. Πολλαπλασιασμός 4. Διαίρεση
    5. Έξοδος

    Όταν επιλεχθεί ‘5’ τότε το πρόγραμμα τερματίζει, διαφορετικά επαναλαμβάνεται η επιλογή με μια νέα πράξη. Να γίνεται έλεγχος της επιλογής για τα νούμερα 1, 2, 3, 4 και 5.

    Πρόβλημα Γ.4

    Να γραφεί πρόγραμμα το οποίο να διαβάζει το ονοματεπώνυμο και τρεις βαθμούς ενός μαθητή. Στη συνέχεια να υπολογίζει και να τυπώνει τον ΜΟ και το μήνυμα ‘ΕΠΙΤΥΧΩΝ’ αν ΜΟ>10, διαφορετικά να εμφανίζει το μήνυμα ΆΠΟΤΥΧΩΝ’. Στη συνέχεια να τυπώνει το μήνυμα: ‘Θέλεις να συνεχισείς για άλλον μαθητή (Ν/Ο)?’ Αν πληκτρολογηθεί ‘Ν’ τότε να επαναλαμβάνονται τα παραπάνω και για άλλον μαθητή, διαφορετικά να τερματίζει το πρόγραμμα.

    Πρόβλημα Γ.5

    Να γραφεί πρόγραμμα το οποίο θα διαβάζει 1000 αριθμούς από το πληκτρολόγιο και θα βρίσκει και θα τυπώνει τον μεγαλύτερο απ’ αυτούς.

    Πρόβλημα Γ.6

    Να γραφεί πρόγραμμα, το οποίο θα υπολογίζει και θα τυπώνει τον μεγαλύτερο και τον μικρότερο από 1000 αριθμούς που εισάγονται από το πληκτρολόγιο.

    Πρόβλημα Γ.1

    Να γραφεί πρόγραμμα, το οποίο να βρίσκει και να τυπώνει τον μεγαλύτερο και τον μικρότερο από τους αριθμούς που εισάγονται από το πληκτρολόγιο. Το τέλος της πληκτρολόγησης δηλώνεται αν πληκτρολογήσουμε τον αριθμό 0.

    Πρόβλημα Γ.7

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ» το οποίο να υπολογίζει τα παρακάτω αθροίσματα:

    1 + 3 + 5 + …+ 99

    1/2 + 1/4 + 1/6 + …. + 1/100

    22 + 42 + … + 1002

    Πρόβλημα Γ.8

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει θετικό ακέραιο αριθμό Ν. Στη συνέχεια, να διαβάζει θετικούς αριθμούς μέχρι το άθροισμά τους να γίνει μεγαλύτερο από τον αριθμό Ν. Τέλος, να υπολογίζει και να τυπώνει τον μεγαλύτερο αριθμό που πληκτρολογήθηκε. Να γίνεται έλεγχος των αριθμών που πληκτρολογούνται, ώστε να είναι θετικοί, σε αντίθετη περίπτωση να εμφανίζεται μήνυμα λάθους και να ζητείται η πληκτρολόγηση ενός θετικού αριθμού.

    Πρόβλημα Γ.9

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τα ονόματα των 26 μαθητών μιας τάξης και 10 βαθμούς για τον κάθε μαθητή. Το πρόγραμμα να υπολογίζει και να εμφανίζει τον Μέσο Όρο για κάθε μαθητή. Στο τέλος το πρόγραμμα να τυπώνει το όνομα του μαθητή με τον μεγαλύτερο μέσο όρο, το όνομα του μαθητή με τον μικρότερο μέσο όρο καθώς και τον μέσο όρο τους αντίστοιχα. Θεωρήστε ότι ο μέσος όρος κάθε μαθητή είναι μοναδικός.

    Πρόβλημα Γ.10

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το πλήθος των μαθητών ενός σχολείου. Στη συνέχεια να διαβάζει τον μέσο όρο κάθε μαθητή. Να υπολογίζει και να τυπώνει το πλήθος και το αντίστοιχο ποσοστό των μαθητών που έχουν μέσο όρο<10, των μαθητών με μέσο όρο στο διάστημα [10,18] και των μαθητών με μέσο όρο >18.

    Πρόβλημα Γ.11

    Ο βαθμός που πληκτρολογείται είναι από 1 μέχρι 20. Το πρόγραμμα να κάνει έλεγχο εγκυρότητας του βαθμού και στην περίπτωση που δίνεται βαθμός έξω από τα επιτρεπτά όρια, να τυπώνει το μήνυμα «Μη αποδεκτή βαθμολογία. Ξαναπροσπαθήστε….».

    Πρόβλημα Γ.12

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει πραγματικούς αριθμούς και να υπολογίζει και να εμφανίζει το άθροισμα και το πλήθος των αριθμών που πληκτρολογήθηκαν. Το πρόγραμμα να διαβάζει πραγματικούς αριθμούς μέχρι να πληκτρολογήσουμε το 100 ή όταν το άθροισμα των αριθμών που έχουν πληκτρολογηθεί γίνει ίσο με 1.000.000.

    Ο αριθμός 100 που σηματοδοτεί και το τέλος της πληκτρολόγησης θα λαμβάνεται υπόψη στο άθροισμα και στο πλήθος.

    Πρόβλημα Γ.13

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει έναν ακέραιο αριθμό και να υπολογίζει και να τυπώνει:

    1. το άθροισμα των ψηφίων του, και
    2. 2. το πλήθος των ψηφίων του

    Πρόβλημα Γ.14

    Η σχολή Θετικών Επιστημών ενός Πανεπιστημίου έχει 4 τμήματα. Κάθε τμήμα δέχεται κάθε χρονιά 150 φοιτητές. Η πρυτανεία αποφάσισε για το τρέχον έτος να κάνει μια στατιστική μελέτη για κάθε τμήμα. Έτσι, αποφάσισε να υπολογίσει το ποσοστό των αριστούχων, δηλ. των νεοεισαχθέντων φοιτητών με βαθμό μεγαλύτερο ή ίσο του 19, ανά σχολή.

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει τους βαθμούς εισαγωγής των φοιτητών και να υπολογίζει και να τυπώνει :
    1. το ποσοστό των αριστούχων φοιτητών κάθε τμήματος, και
    2. σε ποιο τμήμα εισήχθη ο φοιτητής με τον μεγαλύτερο βαθμό.

    Θεωρήστε ότι ο μεγαλύτερος βαθμός είναι μοναδικός.

    Πρόβλημα Γ.15

    Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να περιγράφει τη λειτουργία ενός συγκεκριμένου ασανσέρ. Ο θάλαμος του ασανσέρ χωράει μέχρι 8 άτομα με το μέγιστο συνολικά επιτρεπτό ωφέλιμο βάρος των ατόμων να είναι 900 κιλά. Το ασανσέρ ξεκινά όταν το σύνολο των ατόμων στον θάλαμο δεν ξεπερνά τους οκτώ ή όταν το συνολικό βάρος των ατόμων δεν υπερβαίνει τα 900 κιλά ή όταν δεν υπάρχει άλλο άτομο να εισέλθει σε αυτό από τον κάθε όροφο που έχει σταματήσει. Το ασανσέρ κάνει συνολικά 8 στάσεις (μία σε κάθε όροφο). Σε κάθε στάση, εκτός της τελευταίας, το πρόγραμμα εμφανίζει το μήνυμα «Υπάρχει άτομο να εισέλθει; (ΝΑΙ ή ΟΧΙ)». Αν η απάντηση είναι «ΝΑΙ» τότε «εισάγεται» το βάρος του ατόμου και έτσι σηματοδοτείται η πρόθεσή του να εισέλθει στο ασανσέρ. Η παραπάνω διαδικασία επαναλαμβάνεται μέχρι να δοθεί η απάντηση «ΟΧΙ».

    Επίσης, σε κάθε στάση, εκτός από την πρώτη, το πρόγραμμα εμφανίζει το μήνυμα «Υπάρχει άτομο να εξέλθει; (ΝΑΙ ή ΟΧΙ)», αν η απάντηση είναι «ΝΑΙ» τότε «εξάγεται» το βάρος του ατόμου κι έτσι σηματοδοτείται η έξοδός του από το ασανσέρ. Η παραπάνω διαδικασία επαναλαμβάνεται μέχρι να δοθεί η απάντηση «ΟΧΙ».

    Το πρόγραμμα υπολογίζει και τυπώνει:

    –  το σύνολο των ατόμων που εισέρχονται στον θάλαμο του ασανσέρ σε κάθε στάση (εκτός
    της τελευταίας στάσης),

    –  το σύνολο των ατόμων που εξέρχονται από κάθε στάση (εκτός της πρώτης στάσης),

    –  σε όλες τις στάσεις, πλην της 8ης, το πλήθος των ατόμων που βρίσκονται στον θάλαμο αμέσως πριν την εκκίνηση του ασανσέρ για την επόμενη στάση.

    –  σε όλες τις στάσεις, πλην της 8ης,το συνολικό βάρος των ατόμων που βρίσκονται στον θάλαμο αμέσως πριν την εκκίνηση του ασανσέρ για την επόμενη στάση.
    Σημειώνεται ότι:
    – η λειτουργία του ασανσέρ επιτρέπει μία μόνο μετάβαση από την 1η μέχρι και την 8η στάση – στην 1η στάση επιτρέπεται μόνο η είσοδος και όχι η έξοδος από τον θάλαμο,
    – στην 8η στάση εξέρχονται όλοι από τον θάλαμο χωρίς να επιτρέπεται νέα είσοδος.

ΕΠΑΝΑΛΗΨΗ ΑΕΠΠ ΘΕΜΑΤΑ ΑΠΟ ΔΙΑΔΥΚΤΥΟ

Οι ασκήσεις που ακολουθούν αποτελούν συλλογή θεμάτων από το Διαδίκτυο. Όπου είναι γνωστή η πηγή αυτή αναφέρεται.


1. Να γραφεί αλγόριθμος ο οποίος διαβάζει έναν αριθμό σε δραχμές, τον μετατρέπει σε ευρώ και κατόπιν τον εμφανίζει. Η διαδικασία αυτή θα πρέπει να επαναλαμβάνεται ξανά και ξανά, μέχρι ο υπολογιστής να διαβάσει την τιμή 0. Στο τέλος, θα πρέπει επίσης να εμφανίζει και το πλήθος των αριθμών που διάβασε και μετέτρεψε.

(1 ευρώ=345 δραχμές).

http://www.kavvalos.eu/portal/ανάπτηξη-εφαρμογών/δομή-επανάληψης-αεππ


2. Να γραφεί Αλγόριθμος όπου θα υπολογίζει το ποσό πληρωμής που θα πρέπει να πληρώσει κάθε καταναλωτής ηλεκτρικού ρεύματος της ΔΕΗ.
Για κάθε πελάτη ο αλγόριθμός θα μας ζητά την κατανάλωση σε Κιλοβατώρες (Kw/H), όπου δεν θα πρέπει να είναι αρνητικός αριθμός. Μετά την εισαγωγή των Kw/H, ο αλγόριθμος θα υπολογίζει το ποσό πληρωμής ανάλογα με την κατανάλωση του πελάτη και θα το εμφανίζει.

Επίσης θα ρωτάει τον χρήστη αν επιθυμεί να γίνει τερματισμός του αλγόριθμου ή όχι, κάνοντας την ανάλογη ερώτηση. Σε περίπτωση αρνητικής απάντησης η διαδικασία θα επαναλαμβάνεται για νέο πελάτη.

 

Κατανάλωση (Κwh) Χρέωση (Ευρώ)
0-100 0.015
101-250 0.0015
251-300 0.0035
300-  0.0045

Ο αλγόριθμος πριν τερματίσει θα εμφανίζει το σύνολο των εσόδων καθώς και το πλήθος των πελατών που προσήλθαν στο ταμείο.


3. Το υπουργείο οικονομικών επιβάλλει τέλη κυκλοφορίας στα ιδιωτικής χρήσεως επιβατηγά οχήματα (αυτοκίνητα και δίκυκλα) ανάλογα με τον κυβισμό τους σύμφωνα με τον παρακάτω πίνακα :

Να γραφεί αλγόριθμος ο οποίος :

α) να διαβάζει τον τύπο του οχήματος ( Δ = Δίκυκλο, Α = Αυτοκίνητο ) και τον κυβισμό του.

β) να υπολογίζει τα αντίστοιχα τέλη κυκλοφορίας του οχήματος

γ) να εμφανίζει το ποσό που αναλογεί

Σημείωση : Να θεωρήσετε θετικό τον αριθμό του κυβισμού

 

Τύπος Οχήματος

Κυβισμός

Τέλος Κυκλοφορίας

Δίκυκλα

Μέχρι 500 cc

50 €

Δίκυκλα

Από 501cc και άνω

100 €

Αυτοκίνητα

Μέχρι 1358 cc

200 €

Αυτοκίνητα

Από 1359 μέχρι 1750 cc

 220€

Αυτοκίνητα

Από 1751 μέχρι 2000 cc

250 €

Αυτοκίνητα

Από 2000cc και άνω

600 €

Ο αλγόριθμος θα τερματίζει όταν ως τύπος οχήματος δοθεί ο χαρακτήρας Ν.


4. Μια εταιρία απασχολεί 30 υπαλλήλους. Οι μηνιαίες αποδοχές κάθε υπαλλήλου κυμαίνονται από 0 € έως και 3.000 €.

Α. Να γράψετε αλγόριθμο που για κάθε υπάλληλο:

  • Θα διαβάζει το ονοματεπώνυμο και τις μηνιαίες αποδοχές και θα ελέγχει την ορθότητα καταχώρησης των μηνιαίων αποδοχών του.

  • Θα υπολογίζει το ποσό του φόρου κλιμακωτά, σύμφωνα με τον παρακάτω πίνακα:

    Μηνιαίες Αποδοχές

    Ποσοστό Κράτησης Φόρου

    έως και 700 € 

    0%

    άνω των 700 € έως και 1.000 €

    15 %

    άνω των 1.000 € έως και 1.700 €

    30 %

    άνω των 1.700 €

    40 %

 

Θα εμφανίζει το ονοματεπώνυμο, τις μηνιαίες αποδοχές, το φόρο και τις καθαρές μηνιαίες αποδοχές που προκύπτουν μετά την αφαίρεση του φόρου.

Τέλος ο παραπάνω αλγόριθμος θα υπολογίζει και θα εμφανίζει:

  • Το συνολικό ποσό που αντιστοιχεί στο φόρο όλων των υπαλλήλων.

  • Το συνολικό ποσό που αντιστοιχεί στις καθαρές μηνιαίες αποδοχές όλων τον υπαλλήλων.

http://lykagias.files.wordpress.com/2012/02/askiseis-domi-epanalipsis1.pdf


5. Η υπηρεσία ταχυδρομείων έχει χωρίσει την περιοχή ευθύνης της σε 3 μεγάλες ζώνες για καλύτερη οργάνωση διακίνησης της αλληλογραφίας. Όλα τα γράμματα μοιράζονται στις 3 ζώνες και στη συνέχεια καλούνται οι ταχυδρόμοι κάθε ζώνης να τα διανείμουν στον προορισμό τους.
Όμως κάθε ταχυδρόμος μπορεί να μοιράσει το πολύ 50 γράμματα. Έτσι,αν για μία ζώνη υπάρχουν 40 γράμματα, θα χρειαστεί 1 ταχυδρόμος, αν υπάρχουν 63 γράμματα, θα χρειαστούν 2 ταχυδρόμοι, ενώ αν υπάρχουν 124 γράμματα θα χρειαστούν 3 ταχυδρόμοι.

Να αναπτυξετε αλγόριθμο που:

α. Θα διαβάζει για κάθε γράμμα που εισέρχεται τη ζώνη που αντιστοιχεί (“Α” ή “Β” ή “Γ”) μέχρι να δοθεί ως ζώνη το κενό (να πραγματοποιείται έλεγχος εγκυρότητας για την τιμή που διαβάζεται).

β. Θα υπολογίζει πόσα γράμματα πρέπει να διαμοιραστούν σε κάθε ζώνη.

γ. Θα υπολογίζει και θα εμφανίζει πόσοι ταχυδρόμοι χρειάζονται συνολικά τη μέρα αυτή.


6. Η χρέωση (ΚΛΙΜΑΚΩΤΗ) στους λογαριασμούς της KARBOUNO_POWER είναι η εξής:

Πάγιο

15€

Αστικές

0.030€ ανα μονάδα

Υπεραστικές

0-150 μοναδες

0.045€ ανα μονάδα

151 – 500 μονάδες

0.039 € ανά μονάδα

501 και πάνω μονάδες

0.033€ ανά μονάδα

Να αναπτύξετε αλγόριθμο που:

1) Θα διαβάζει επαναληπτικά το όνομα ενός συνδρομητή, τις αστικές και υπεραστικές μονάδες που κατανάλωσε (εξασφαλίζοντας ότι είναι θετικές τιμές)  μέχρι να διαβαστεί ως όνομα το “Τ3Λ0$”.

2)Για κάθε συνδρομητή θα εκτυπώνει το λογαριασμό του.

3)Θα εκτυπώνει τις συνολικές εισπράξεις της KARBOUNO_POWER.

4) Θα εκτυπώνει το όνομα του πιο σπάταλου καταναλωτή.

5)Θα εκτυπώνει το μέσο όρο των λογαριασμών.


7. Η χρέωση των ΙΧ αυτοκινήτων που μετακινούνται μ’ ένα οχηματαγωγό πλοίο είναι ανάλογη του μήκους τους ως εξής :

έως και 2 μέτρα είναι 3 €, έως και 3 μέτρα είναι 6 € και για παραπάνω από 3 μέτρα είναι 9 €. Να διαβασθούν τα μήκη 10 αυτοκινήτων που μετακινήθηκαν μ’ ένα οχηματαγωγό πλοίο και να υπολογισθεί το συνολικό ποσό είσπραξης.


8. Μια εταιρεία ενοικίασης αυτοκινήτων χρεώνει την πρώτη ημέρα ενοικίασης προς 100 € και κάθε επόμενη ημέρα μέχρι και την 10η προς 50 €. Όμως, αν ένα αυτοκίνητο νοικιαστεί για περισσότερες από 10 ημέρες, τότε θα χρεωθεί όλες τις ημέρες προς 30 € την ημέρα. Να διαβασθούν οι ημέρες Μ που νοικιάσθηκε ένα αυτοκίνητο και να βρεθεί η χρέωσή του. Να επεκταθεί ο αλγόριθμος ώστε να δουλεύει για Ν αυτοκίνητα.


9. Η ωριαία αμοιβή ενός εργαζομένου είναι 6 €. Όμως, αν οι ώρες εργασίας του είναι περισσότερες από 25, λαμβάνει και επιπλέον υπερωριακή αποζημίωση 3 € για κάθε επιπλέον ώρα. Να διαβασθούν οι ώρες εργασίας και να υπολογισθούν οι αποδοχές κάθε ενός από τους 100 εργαζομένους μιας εταιρείας (κανονική αμοιβή, αμοιβή υπερωριών και συνολικές αποδοχές).

http://aepp-1.blogspot.gr/2012/10/blog-post.html


10.


11. Να αναπτυχθεί αλγόριθμος που να διαβάζει τον λογαριασμό πληρωμής σε ένα κατάστημα. Όταν το ποσό υπερβαίνει τα 1000 € να εκτυπώνεται μήνυμα : “Πάλι το παράκανες!” και να σταματά η επαναληπτική διαδικασία.


12. Μια τάξη της Τεχνολογικής Κατεύθυνσης της Γ Λυκείου έχει 25 μαθητές, οι οποίοι εξετάστηκαν στις Πανελλήνιες Εξετάσεις στο μάθημα “Ανάπτυξη Εφαρμογών”. Να γίνει πρόγραμμα το οποίο:
Α) Για κάθε μαθητή
        – θα ζητάει τον προφορικό και το γραπτό του βαθμό (όλοι οι βαθμοί είναι στην 20βάθμια κλίμακα).
     – θα εμφανίζει την τελική του βαθμολογία, η οποία εξάγεται κατά 70% από το γραπτό και κατά 30% από τον προφορικό του βαθμό.
Β) Θα εμφανίζει το επί τοις εκατό ποσοστό των μαθητών που έχουν τελική βαθμολογία μεγαλύτερη από 15.

http://glossomatheia.studies.gr/programs/viewforum.php?f=15&sid=fd8e8dbbe01ff7bf465c24ba0d456a88


13. Ο Δείκτης Μάζας του ανθρώπινου Σώματος (ΔΜΣ) υπολογίζεται από το βάρος (Β) σε χλγ. και το ύψος (Υ) σε μέτρα με τον τύπο ΔΜΣ=Β/Υ^2.
Ο ανωτέρω τύπος ισχύει για άτομα άνω των 16 ετών.
Το άτομο ανάλογα με την τιμή του ΔΜΣ χαρακτηρίζεται σύμφωνα με τον παρακάτω πίνακα:

ΔΜΣ < 18,5                     “αδύνατο άτομο”
18,5 <= ΔΜΣ <=25       “κανονικό άτομο”
25 < ΔΜΣ                       “βαρύ άτομο”

Να γράψετε πρόγραμμα το οποίο:

α. να διαβάζει το όνομα, την ηλικία, το βάρος και το ύψος κάθε ατόμου για ένα σχολείο  150 μαθητών.

β. εάν η ηλικία είναι μεγαλύτερη των 16 ετών, τότε

1.  να υπολογίζει το ΔΜΣ

2.  να ελέγχει την τιμή του ΔΜΣ από τον ανωτέρω πίνακα και να εμφανίζει τον αντίστοιχο χαρακτηρισμό

γ. εάν η ηλικία είναι μικρότερη ή ίση των 16 ετών, τότε να εμφανίζει το μήνυμα “δεν ισχύει ο δείκτης ΔΜΣ”.

δ. να εμφανίζει το όνομα του μαθητή με το μεγαλύτερο ΔΜΣ.

ε. να εμφανίζει τις ηλικίες των μαθητών οι οποίοι έχουν ΔΜΣ υψηλότερο από το μέσο όρο του σχολείου. Ο μέσος όρος ΔΜΣ του σχολείου προκύπτει μόνο από τους μαθητές με ηλικία >16.

γιατί δεν μπορεί να απαντηθεί αυτό το ερώτημα;

Παρατήρηση:   Θεωρήστε ότι το βάρος, το ύψος και η ηλικία είναι θετικοί αριθμοί  και μην ασχοληθείτε με τον έλεγχο τους.


14. Να γραφεί πρόγραμμα το οποίο να ζητά από το χρήστη το Μισθό ενός εργαζόμενου καθώς και την ειδικοτητά του. Κατόπιν να υπολογίζει το ποσό των εισφορών το οποίο θα πρέπει να καταβάλλει ο εργαζόμενος, καθώς και το ύψος του τελικού μισθού του, σύμφωνα με τα παρακάτω στοιχεία:

ΥΨΟΣ ΜΙΣΘΟΥ          ΕΙΣΦΟΡΑ1       ΕΙΣΦΟΡΑ2
μέχρι 1500 ευρώ             5%                        4%
από 1501 – 2500              7%                        6%
από 2501 – 4000             9%                        8%
από 4001 –                       12%                      11%

Αν ο εργαζόμενος έχει ειδικότητα ‘ΤΕΧΝΙΚΟΣ’ τότε ή ΕΙΣΦΟΡΑ1 προσαυξάνεται κατά 3% και ή ΕΙΣΦΟΡΑ2 κατά 4%, ενώ αν ο εργαζόμενος έχει ειδικότητα ΠΩΛΗΤΗΣ τότε ή ΕΙΣΦΟΡΑ1 προσαυξάνεται κατά 4% και ή ΕΙΣΦΟΡΑ2 κατά 5%. Τέλος το σύνολο των εισφορών που καλείται να πληρώσει ο εργαζόμενος δεν μπορεί να υπερβεί σε καμμία περίπτωση το ποσό των 5000 ευρώ. Η διαδικασία θα τερματίζεται όταν δοθεί μισθός 0.

(panos giannakopoulos)


15. Οι υπάλληλοι μιας εταιρίας συμφώνησαν για το μήνα Δεκέμβριο να κρατηθούν από το μισθό τους δύο ποσά ένα για τη διοργάνωση εκδηλώσεων στο χώρο της δουλείας τους τις ημέρες των γιορτών και ένα για τη βελτίωση του χώρου εργασίας τους (parking ιδιωτικό, θέρμανση, απολύμανση, κ.λ.π.).
Ο υπολογισμός του ποσού των εισφορών εξαρτάται από τον αρχικό μισθό του υπαλλήλου και υπολογίζεται με βάση τα παρακάτω όρια μισθών:

ΜΙΣΘΟΣ                   ΕΚΔΗΛΩΣΕΙΣ                ΒΕΛΤΙΩΣΗ_ΧΩΡΟΥ
ΕΩΣ 600 ΕΥΡΩ                  3%                                       5%
600,01 ΕΩΣ  900               5%                                       7%
900,01 ΕΩΣ 1300              6%                                       9%
1300,01 ΕΩΣ 1800            7%                                       10%
ΠΑΝΩ ΑΠΟ 1800,01        8%                                      12%

Να διαβάζεται το πλήθος των υπαλλήλων, η ειδικότητα του καθενός και αν είναι ΤΕΧΝΙΚΟΣ τοτε να προστίθεται 1% και 2% αντίστοιχα. Αν είναι ΠΩΛΗΤΗΣ προστίθεται 3% και 4% αντίστοιχα. Η συνολική προσφορά να μην ξεπερνά τα 700 Ευρώ.


16. Σε ένα μπλόκο της τροχαίας ακολουθείται το εξής σύστημα: Κάθε οδηγός υπόκειται σε αλκοτέστ, ο μετρητής του οποίου έχει ενδείξεις από 0 μέχρι 5 (0 = νηφάλιος). Αν η μέτρηση κάποιου οδηγού είναι μεγαλύτερη από 0, τότε το διπλάσιό της προστίθεται στο σύστημα πόντων (point system) του οδηγού. Αν αυτός συγκεντρώσει:

1 έως 3 μονάδες, δεν υπάρχει πρόβλημα.
4 έως 6 μονάδες, του γίνεται σύσταση,
7 έως 9 μονάδες, πληρώνει πρόστιμο,
περισσότερες από 9 μονάδες, του αφαιρείται το δίπλωμα. Αν του έχει αφαιρεθεί και άλλη φορά, κινείται δικαστική διαδικασία.

Να γίνει πρόγραμμα το οποίο:
α) Να ζητάει τους πόντους που είχε συγκεντρώσει κάποια δεδομένη στιγμή ένας οδηγός.
β) Να ζητάει τη μέτρηση του αλκοτέστ και την ώρα που αυτή πραγματοποιήθηκε και να αυξάνει όπως προβλέπεται τους πόντους του οδηγού.
γ) Ανάλογα με τους πόντους που έφτασε τώρα ο οδηγός, να εμφανίζει ένα από τα μηνύματα:
“ΚΑΝΕΝΑ ΠΡΟΒΛΗΜΑ”, “ΣΥΣΤΑΣΗ”, “ΠΡΟΣΤΙΜΟ”, “ΑΦΑΙΡΕΣΗ ΔΙΠΛΩΜΑΤΟΣ”.
δ) Σε περίπτωση που πρέπει να του αφαιρεθεί το δίπλωμα, το πρόγραμμα πρέπει να ρωτάει αν του έχει αφαιρεθεί και άλλη φορά. Αν η απάντηση είναι “ΝΑΙ” τότε να εμφανίζεται το μήνυμα “ΔΙΚΑΣΤΙΚΑ ΜΕΤΡΑ”. Σε περίπτωση που η απάντηση δεν είναι ούτε “ΝΑΙ” ούτε “ΟΧΙ”, θα πρέπει να επαναλαμβάνεται η ερώτηση.

Ο αλγόριθμος θα τερματίζει όταν ως ώρα δοθεί 06:00.


17. Το πρόγραμμα “θερμοστάτης” προσομειώνει τη λειτουργία ενός θερμοστάτη. Συγκεκριμένα, δίνεται η επιθυμητή θερμοκρασία (ΤΕ), δηλαδή αυτή στην οποία ο χρήστης θέλει να σταματήσει η λειτουργεία του καλοριφέρ και η στιγμαία θερμοκρασία (ΤΣ), που είναι η θερμοκρασία του χώρου μια συγεκριμμένη στιγμή. Αν ΤΣ<ΤΕ, τότε ζητάται νέα στιγμιαία θερμοκρασία. Αν ΤΣ>ΤΕ, τότε εμφανίζεται κατάλληλο μήνυμα που λέει όι η θεμροκρασία του χώρου έχει υπερβεί την επιθυμητή θερμοκρασία και ΤΣΕΚ <– 1. Αυτό γίνεται, αν και δεν ισχύει στην πράξη, διότι δεν υπάρχει αισθητήρας και ο χρήστης είναι ελεύθερος να δώσει ό,τι θερμοκρασία θέλει. Αν ΤΣ>=ΤΕ, το πρόγραμμα βγαίνει από τη δομή επανάληψης, τυπώνοντας κατάλληλο μήνυμα.


18. Το τμήμα πληροφορικής του Οικονομικού Πανεπιστημίου Αθηνών έχει 150 τελειόφοιτους. Η γραμματεία θέλει να εκτιμήσει στατιστικά για την επίδοση των φοιτητών, το ποσοστό επί τοις % των φοιτητών που είχαν επίδοση άριστα, λίαν καλώς και καλώς. Να αναπτυχθεί αλγόριθμος που θα διαβάζει τους μέσους όρους για τους 150 φοιτητές, θα υπολογίζει και θα εκτυπώνει τα ποσοστά αυτά σύμφωνα με τον παρακάτω πίνακα

 

Μέσος όρος

Χαρακτηρισμός

5 – 6.5

Καλώς

6.51 – 8.5

Λίαν καλώς

8.51 και άνω

Άριστα


19. Να αναπτυχθεί αλγόριθμος που θα διαβάζει το πλήθος των αμνοεριφίων στους 52 νομούς της χώρας και να υπολογίζει τον συνολικό πληθυσμό των αμνοεριφίων στη χώρα και το μέσο όρο των νομών.


20. Από έρευνες έχει φανεί ότι μια κοινότητα μελισσών υπό κανονικές συνθήκες αναπτύσσεται με ρυθμό 3.8%. Αν ένας μελισσοκόμος διαθέτει μελίσσια με συνολικό πληθυσμό 1200 μέλισσες σε πόσα έτη θα ξεπεράσει τη χωρητικότητα των κυψελών του που είναι 2000 μέλισσες;


21. Έρευνες έδειξαν ότι ο ετήσιος ρυθμός μείωσης του σπάνιου είδους εντόμων ΧΖΣ∆ είναι 8.75% ενώ ταυτόχρονα εκτιμάται ότι τα έντομα αυτά αριθμούν σήμερα 35000. Για να χαρακτηριστεί ένα είδος εντόμων ως είδος προς εξαφάνιση πρέπει να αριθμεί το πολύ 6000 οργανισμούς. Να αναπτυχθεί αλγόριθμος που θα υπολογίζει και θα εκτυπώνει τα έτη που χρειάζονται ώστε να χαρακτηριστεί ως είδος προς εξαφάνιση το σπάνιο αυτό είδος εντόμων.


22. Οι καταθέσεις σας στην τράπεζα είναι 6500 € και το επιτόκιο της κατάθεσης είναι 5.4%. Να αναπτυχθεί αλγόριθμος που θα υπολογίζει πόσο θα είναι το κεφάλαιο με το πέρας 8 ετών.


23. Οι καταθέσεις σας στην τράπεζα είναι 6500 € και το επιτόκιο της κατάθεσης είναι 5.4%. Να αναπτυχθεί αλγόριθμος που θα υπολογίζει σε πόσα έτη το κεφάλαιο θα ξεπεράσει τα 11.000 €.

http://ptsiotakis.mysch.gr


24. Μια τράπεζα στην προσπάθειά της να προσελκύσει νέους πελάτες παρουσίασε στη δημοσιότητα ένα νέο επενδυτικό πρόγραμμα.
Σύμφωνα με αυτό ο καταθέτης δεσμεύει ένα χρηματικό ποσό (πάνω από 9.000 €) στην τράπεζα για χρονικό διάστημα μεγαλύτερο των 5 ετών. Το ποσό αυτό τοκίζεται με επιτόκιο που κάθε 2 χρόνια αυξάνεται κατά 0.85% με αρχική τιμή το 5.2%.

Να αναπτυχθεί αλγόριθμος που θα διαβάζει το ποσό κατάθεσης και τον χρόνο του επενδυτικού προγράμματος και αν εκπληρούνται τα κριτήρια να εμφανίζει το ποσό που θα έχει στη διάθεσή του τελικά ο πελάτης της τράπεζας.


25. Μια τράπεζα προσφέρει επιτόκιο καταθέσεων 4.7%. Ένας καταθέτης αποφάσισε να καταθέσει 30.000 € στην τράπεζα και στο τέλος κάθε χρόνου να κρατάει το μισό ποσό από τους τόκους και να επανακαταθέτει το άλλο μισό για τον επόμενο χρόνο.
Να αναπτυχθεί αλγόριθμος που θα υπολογίζει και θα εμφανίζει το ποσό που θα έχει συνολικά χρησιμοποιήσει ο καταθέτης μετά από 17 χρόνια.


26. Μια τράπεζα στην προσπάθειά της να προσελκύσει νέους πελάτες παρουσίασε στη δημοσιότητα μια νέα προσφορά. Οποιοσδήποτε κάτοχος πιστωτικής κάρτας σε άλλη τράπεζα μπορεί να μεταφέρει την οφειλή του σ’ αυτήν και να αποπληρώσει το χρέος του με τόκο 10.9% που μειώνεται κάθε έτος κατά 0.9% με ελάχιστη τιμή το 6.5% (δεν μπορεί να πέσει κάτω από αυτή την τιμή).

Να αναπτύξετε αλγόριθμο που θα διαβάζει το ποσό της οφειλής που μετέφερε κάποιος πελάτης στην τράπεζα και να εμφανίζει σε πόσα έτη θα το ξεχρεώσει αν πληρώνει κάθε μήνα το 15% της αρχικής οφειλής.


27. Οι γεννήσεις στην Ελλάδα κατά το έτος 2000 ήταν 100000. Αναμένεται ότι τα επόμενα χρόνια ο αριθμός των γεννήσεων θα αυξάνεται, κατά μέσο όρο κατά 0.2 % ετησίως. Να αναπτυχθεί αλγόριθμος που θα υπολογίζει και θα εμφανίζει σε ποιο έτος οι γεννήσεις θα ξεπεράσουν για πρώτη φορά τις 150000.
Η ανάπτυξη του αλγορίθμου να γίνει και σε διάγραμμα ροής και σε ψευδογλώσσα.


28. Ένας μαθητής που τελείωσε με άριστα την τάξη, ζήτησε έναν υπολογιστή, αξίας 1800€, από τους γονείς του. Οι γονείς του δήλωσαν, ότι μπορούν να του διαθέσουν σταδιακά το ποσό, δίνοντας του κάθε βδομάδα ποσό διπλάσιο από την προηγούμενη, αρχίζοντας από την πρώτη εβδομάδα με 15€. Να αναπτύξετε αλγόριθμο ο οποίος:

α) θα υπολογίζει και θα εμφανίζει μετά από πόσες βδομάδες θα μπορέσει ο μαθητής να αγοράσει τον υπολογιστή του και

β) θα υπολογίζει και θα εμφανίζει πιθανό περίσσευμα χρημάτων.


29. Ένας πελάτης μιας τράπεζας, καταθέτει στην τράπεζα κάποιο ποσό χρημάτων. Η τράπεζα δίνει κυμαινόμενο επιτόκιο ανάλογα με την τιμή του πληθωρισμού στο τέλος του χρόνου.

Υλοποιήστε αλγόριθμο ο οποίος θα δέχεται ως είσοδο το αρχικό ποσό του καταθέτη και τα χρόνια που θα μείνει το ποσό αυτό στην τράπεζα, και θα υπολογίζει το συνολικό τόκο που θα πάρει ο καταθέτης στο τέλος.
Θεωρείστε ότι η κατάθεση αρχίζει με επιτόκιο 5% και κάθε χρόνο μειώνεται κατά 0.22%, μέχρι να πέσει κάτω του 0.15% οπότε και σταθεροποιείται.


30. Ο πληθυσμός μιας χώρας είναι 10 εκατομμύρια και υπολογίζεται ότι παρουσιάζει σταθερή ετήσια αύξηση 2%. Να κάνετε αλγόριθμο που να υπολογίζει το πληθυσμό μετά από 15 χρόνια.


31. Μια εταιρεία γεωτρήσεων ακολουθεί την εξής πολιτική τιμών: Το πρώτο μέτρο γεώτρησης κοστίζει 6 ευρώ και αυξανομένου του βάθους, αυξάνεται και η τιμή κάθε μέτρου κατά 1.5 ευρώ. Να γίνει αλγόριθμος που να διαβάζει το ποσό που διαθέτει ένας πελάτης και να υπολογίζει και εμφανίζει το βάθος στο οποίο μπορεί να πάει η γεώτρηση.


32. Με την εκκίνηση της συσκευής του κινητού ζητείται ο κωδικός πρόσβασης και ο χρήστης έχει τρεις ευκαιρίες για την εισαγωγή του. Να αναπτύξετε τον αλγόριθμο που εκτελεί το κινητό ζητώντας 3 φορές τον κωδικό πρόσβασης (αν δεν έχει εισαχθεί σωστά) και με τριπλή αποτυχία να εκτυπώνεται το μήνυμα “η κάρτα SIM κλειδώθηκε, παρακαλώ εισάγετε το PUK”

http://www.arnos.gr/dmdocuments/lykeio/lykeioC/anaptyxh.efarmogwn/8ewria/25.aaep.kalaitzi.8ewr.askisieis.sthn.domi.epanalipsis.pdf


33. Στην Ελλάδα αυτή τη στιγμή υπάρχουν 3000000 καπνιστές. Κάθε έτος εκτιμάται οτι ο αριθμός τους αυξάνεται κατά 3.7% . Να γραφεί αλγόριθμος που βρίσκει τον πληθυσμό των καπνιστών μετά από 15 έτη καθώς και το ποσοστό μεταβολής αυτών και να εκτυπωθούν.


34. Το έντομο ΑΒΒΑ αυτή τη στιγμή αριθμεί 90120  οργανισμούς.  Αν κάθε έτος ο πληθυσμός του μειώνεται κατά 9.1% να γραφεί αλγόριθμος που υπολογίζει σε πόσα έτη θα θεωρηθεί ως είδος προς εξαφάνιση (πληθυσμός <6000).

http://www.aepp100.gr/2012/12/12/ασκησεισ-στη-δομη-επαναληψησ/


35. Σε ένα μεταφορικό πλοίο μπορούν να εκφορτωθούν 5500 τόνοι. Να αναπτυχθεί αλγόριθμος που θα διαβάζει διαδοχικά το βάρος των φορτίων που τοποθετούνται στο πλοίο έως ότου να γεμίσει και να εκτυπώνει πόσα τεμάχια εκφορτώθηκαν καθώς και ποιο είναι το μέσο βάρος των τεμαχίων αυτών.


36.  Σε μια επαρχιακή πόλη κυκλοφορούν 15000 αυτοκίνητα. Έρευνες έδειξαν οτι ο ετήσιος ρυθμός αύξησης των αυτοκινήτων είναι 11.5 % ενώ ταυτόχρονα οι υποδομές σε δρόμους μπορούν να εξυπηρετήσουν επαρκώς 40000 αυτοκίνητα. Να αναπτυχθεί αλγόριθμος που θα υπολογίζει και θα εκτυπώνει τα έτη που χρειάζονται ώστε να ξεπεράσει το όριο αυτοκινήτων στην πόλη αυτή.


37. Μια μπάλα αφήνεται από ύψος 50 μέτρα. Σε κάθε αναπήδηση φθάνει σε ύψος 4/5 του προηγούμενου. Να αναπτύξετε αλγόριθμο που θα υπολογίζει τον πλήθος των αναπηδήσεων που απαιτούνται ώστε να ακινητοποιηθεί η μπάλα.


38. 


39. Εκτροφείο σκύλων εκτρέφει γερµανικούς ποιµενικούς. Ο καλύτερος όµως πελάτης του εκτροφείου εκτός από πολύ πλούσιος είναι και πολύ απαιτητικός. Έτσι εξέφρασε την επιθυµία να αγοράσει το λυκόσκυλο που έχει το δυνατότερο δάγκωµα. Οι υπεύθυνοι του εκτροφείου δεν ήθελαν να του χαλάσουν χατίρι και έτσι αγόρασαν έναν µετρητή δύναµης. Να γραφεί πρόγραµµα το οποίο θα διαβάζει για κάθε σκύλο την δύναµη του δαγκώµατος του (η διαδικασία να τερµατίζει όταν δοθεί τιµή ίση µε το 0) και θα εµφανίζει ποιο σκυλί είχε το δυνατότερο δάγκωµα.


40. Μία βιοτεχνία ρούχων είχε συνολικά κέρδη για το έτος 2008 60.000 €. Αν οι προβλέψεις είναι για αύξηση των κερδών της βιοτεχνίας κατά 20% για κάθε χρόνο να γραφεί πρόγραµµα το οποίο θα υπολογίζει µετά από πόσα χρόνια τα ετήσια κέρδη της θα ξεπεράσουν τα 100.000 €.


41. Έστω ότι η ΝΑΣΑ θέλει να ξεκινήσει ένα πρόγραµµα αποικισµού του Άρη. Σύµφωνα µε τον προγραµµατισµό της ΝΑΣΑ τον πρώτο χρόνο θα µεταφερθούν 100 άτοµα και κάθε επόµενο έτος θα µεταφέρονται διπλάσια άτοµα από την προηγούµενη (τα άτοµα όµως που µεταφέρονται σε έναν χρόνο δεν µπορούν να υπερβαίνουν τα 1000).

Να γραφεί πρόγραµµα το οποίο θα υπολογίζει µετά από πόσα χρόνια ο αριθµός των αποίκων θα φτάσει τον αριθµό των 20.000.

Σαρηµπαλίδης Ιωάννης


42. To κεντρικό αμφιθέατρο της Σχολής Θετικών Επιστημών (ΣΘΕ) έχει 30 σειρές εδράνων.
Η κάτω-κάτω σειρά (1η σειρά) αποτελείται από 20 έδρανα και για κάθε σειρά πιο πάνω τα έδρανα αυξάνονται κατά 3. Η ΣΘΕ αποφάσισε να περάσει με βερνίκι όλα τα έδρανα. Κάθε έδρανο απαιτεί 2000 gr βερνικιού, και ο προμηθευτής στης ΣΘΕ, διαθέτει βερνίκι σε κουτιά των 7 Kg με κόστος 4 € το καθένα.
Να γίνει αλγόριθμος που να υπολογίζει πόσα έδρανα έχει συνολικά το αμφιθέατρο, πόσα κουτία βερνίκι απαιτούνται, και ποιο είναι το συνολικό κόστος.


43. Σε μια θεατρική παράσταση σε ένα περιφερειακό θέατρο οι ενήλικοι (ηλικία >= 18) πληρώνουν 25 Ευρώ, ενώ οι ανήλικοι 12 Ευρώ. Αν ένας ενήλικος έχει εκπτωτικό κουπόνι τότε πληρώνει 2.5% λιγότερο, ενώ οι ανήλικοι με κουπόνι έκπτωσης πληρώνουν 10 Ευρώ. Να γραφεί αλγόριθμος που θα:

α) διαβάζει την ηλικία ενός πελάτη, τα χρήματα που έδωσε στον ταμία, και αν έχει ή όχι κουπόνι έκπτωσης (δίνεται ως μεταβλητή τύπου χαρακτήρα: Ν αν έχει, Ο αν δεν έχει κουπόνι έκπτωσης),

Μονάδες 2

β) βρίσκει πόσα χρήματα πρέπει να πληρώσει και θα τα εκχωρεί σε μια μεταβλητή Π,

Μονάδες 8

γ) εμφανίζει τα χρήματα που πρέπει να πληρωθούν.

Μονάδες 2

δ) Στη συνέχεια να γίνεται έλεγχος αν τα χρήματα που πληρώθηκαν είναι περισσότερα, λιγότερα ή ίσα με αυτά που έπρεπε να πληρωθούν. Αν είναι περισσότερα να υπολογίζει και να εμφανίζει τα ρέστα. Αν είναι λιγότερα να εμφανίζει πόσα χρήματα απομένουν να πληρωθούν. Αν είναι ακριβώς, να εμφανίζει το μήνυμα “Ευχαριστώ”.

Μονάδες 8

http://rea.teimes.gr/~lazarinf/DiagonismaProvlima_Epanalipsi.doc


44. Ένα μαγαζί που πουλάει φιλμ χρεώνει κλιμακωτά τους πελάτες του ως εξής:

Για τα πρώτα 10 φιλμ προς 3.50 Ευρώ το ένα
Για τα επόμενα 20 φιλμ προς 3.10 Ευρώ το ένα
Για τα επόμενα 40 φιλμ προς 2.70 Ευρώ το ένα
Για τα υπόλοιπα φιλμ προς 2.20 το ένα

Να γραφεί αλγόριθμος που να υπολογίζει τι πρέπει να πληρώσει κάποιος που θέλει να αγοράσει φιλμ.
Επίσης, να διαβάζεται η μάρκα του φιλμ:

Αν είναι KODAK να προστίθεται 0.40 Ευρώ στην τιμή του ενός φιλμ.
Αν είναι AGFA να προστίθεται 0.30 Ευρώ στην τιμή του ενός φιλμ.
Αν είναι FUJIFILM να προστίθεται 0.20 Ευρώ στην τιμή του ενός φιλμ.
Ειδάλλως, να μην προστίθεται τίποτα.

Τέλος, αν συνολικό κόστος πάνω από 900 τότε 15% έκπτωση.

Για την συνέχιση της επαναληπτικής διαδικασίας ο χρήστης θα ερωτάται αν επιθυμεί να συνεχίσει ή όχι.


45. Μια εταιρεία κινητής τηλεφωνίας ακολουθεί ανά μήνα την πολιτική τιμών δύο προγραμμάτων “Πρόγραμμα 1” και “Πρόγραμμα 2” που φαίνεται στους παρακάτω πίνακες :

Πρόγραμμα 1

Πάγιο 10 €

Μήνυμα SMS 0.08 €

Χρόνος τηλεφωνημάτων (λεπτά)

Χρονοχρέωση (€ / λεπτό)

1 – 40

Χωρίς χρέωση

Πάνω από 40 – 90

0.23 €

Πάνω από 90 – 120

0.21 €

Πάνω από 120

0.19 €

Πρόγραμμα 2

Πάγιο 15 €

Μήνυμα SMS 0.08 €

Χρόνος τηλεφωνημάτων (λεπτά)

Χρονοχρέωση (€ / λεπτό)

1 – 60

Χωρίς χρέωση

Πάνω από 60 – 120

0.20 €

Πάνω από 120

0.19 €

Να γραφεί αλγόριθμος ο οποίος :

(Α) να διαβάζει για κάθε συνδρομητή το είδος του προγράμματός του (1 ή 2), τη χρονική διάρκεια των τηλεφωνημάτων σε λεπτά και τα μηνύματα που έστειλε σε διάρκεια ενός μηνός.

(Β) να υπολογίζει τη μηνιαία χρέωση του συνδρομητή κλιμακωτά.

(Γ) να εμφανίζει τη μηνιαία χρέωση του συνδρομητή με το ΦΠΑ 19%.

Ο αλγόριθμος να τερματίζει όταν δοθεί ως είσοδος μη αποδεκτό είδος προγράμματος.

(20 Μονάδες)

Ευριπίδης Βραχνός, Ηλίας Καρυοφύλης, Ελένη Κοκκίνου, Ανδρέας Πυρόβολος


46. Στο τμήμα Επιστήμης Υπολογιστών, ένας φοιτητής έχει τις εξής υποχρεώσεις στα πλαίσια του μαθήματος «Λειτουργικά Συστήματα»: να κάνει 3 ασκήσεις, να δώσει μια Πρόοδο (Πρόοδος = διαγώνισμα πριν τις εξετάσεις) και να δώσει την τελική εξέταση. Προϋπόθεση για να συμμετάσχει στην τελική εξέταση είναι ο μέσος όρος των 3 ασκήσεων και της Προόδου να είναι από 5 και πάνω.

Ο υπολογισμός του τελικού βαθμού γίνεται ως εξής :

α) σε περίπτωση που ο βαθμός τελικής εξέτασης είναι κάτω του 5 τότε κάθε βαθμός άσκησης συμμετέχει σε ποσοστό 10% στον τελικό βαθμό, ο βαθμός Προόδου συμμετέχει σε ποσοστό 15% στον τελικό βαθμό και ο βαθμός της τελικής εξέτασης συμμετέχει σε ποσοστό 55% στον τελικό βαθμό.

β) διαφορετικά κάθε βαθμός άσκησης συμμετέχει σε ποσοστό 6% στον τελικό βαθμό, ο βαθμός Προόδου συμμετέχει σε ποσοστό 12% στον τελικό βαθμό και ο βαθμός της τελικής εξέτασης συμμετέχει σε ποσοστό 70% στον τελικό βαθμό.

Να γράψετε πρόγραμμα το οποίο :

    1. Θα διαβάζει τα ονοματεπώνυμα και τους βαθμούς στις υποχρεώσεις στο μάθημα Λειτουργικά Συστήματα ενός συνόλου φοιτητών. Η είσοδος τερματίζεται μόλις δοθεί ως ονοματεπώνυμο το κενό.

    1. Θα υπολογίζει και θα εμφανίζει τον τελικό βαθμό του κάθε φοιτητή που έλαβε μέρος στην τελική εξέταση κάνοντας χρήση συνάρτησης.

    1. Θα εμφανίζει το ποσοστό των φοιτητών που δεν απέκτησαν το δικαίωμα να λάβουν μέρος στην τελική εξέταση .

Ηλίας Καρυοφύλης, Παύλος Κεφαλάκης, Αντώνης Μανουσάκης, Γιώργος Νικολακάκης, Γιώργος Παπαργύρης


47. Ενα σχολείο θέλει να εξοπλίσει το σχολικό εργαστήριο Πληροφορικής. Για το σκοπό αυτό προκήρυξε διαγωνισμό για το κόστος του εξοπλισμού. Το κόστος του εξοπλισμού αφορά τρεις συγκεκριμένες κατηγορίες (Κόστος υπολογιστών, κόστος προγραμμάτων, κόστος περιφερειακών μονάδων). Στον διαγωνισμό συμμετείχαν 12 εταιρείες που έκαναν τις αντίστοιχες προσφορές. Να γραφεί αλγόριθμος που θα :

  1. Διαβάζει τις προσφορές των παραπάνω εταιρειών για κάθε κατηγορία κόστους

Μονάδες 4

  1. Υπολογίζει και εμφανίζει το μέσο κόστος ανά κατηγορία κόστους

Μονάδες 8

  1. Εμφανίζει τις 3 καλύτερες προσφορές

Μονάδες 8


48. Ένας εργαζόμενος προσλαμβάνεται σε μια εταιρία με αρχικό μισθό. Κάθε χρόνο θα παίρνει μηνιαία αύξηση. Από τα χρήματα που συγκεντρώνει το χρόνο αποταμιεύει ένα ποσοστό% με σκοπό κάποια στιγμή να αγοράσει ένα διαμέρισμα που κοστίζει και στο οποίο θέλει να βάλει επίπλωση αξίας Κάθε χρόνο η τιμή του σπιτιού αυξάνεται κατά χ1% και της επίπλωσης κατά χ2%. Να γραφεί πρόγραμμα που θα διεκπεραιώνει τις εξής διεργασίες:

Α) Θα υπολογίζει πόσα χρόνια θα περάσουν μέχρι ο εργαζόμενος να αποκτήσει το δικό του σπίτι.
Β) Θα εξετάζει αν υπάρχει περίσσευμα χρημάτων για να μπορέσει ο εργαζόμενος να αγοράσει την επίπλωση που επιθυμεί.

ΑΕΠΠ ΜΕΤΑΤΡΟΠΕΣ – ΔΙΑΓΡΑΜΜΑΤΑ ΡΟΗΣ

Τα παρακάτω τμήματα αλγορίθμων να μετατραπούν σε διάγραμμα ροής.

Ομάδα ΑΟμάδα Β

Αν Α ≥ 5 τότε

Αν Β < 7 τότε

Α ← Α + 1

αλλιώς

Α ← Α – 1

Τέλος_αν

αλλιώς

Α ← Α – 1

Τέλος_αν

Εμφάνισε Α

 


 

Αν x > 10 τότε

Αν x < 30 τότε

Κ ← 3 * x

Αλλιώς

Κ ← 5 * x

Τέλος_αν

Κ ← Κ / 2

Αλλιώς

Κ ← x

Αν x < 5 τότε

Κ ← 2 * Κ

Τέλος_αν

Τέλος_αν


 

Αν Χ>Y τότε

Αν Y≠1 τότε

Ζ ← Χ/(Y-1)

αλλιώς

Ζ ← Y/X

Τέλος_αν

Εμφάνισε Ζ

Τέλος_αν


 

Αν Α < Β τότε

Αν C <> D τότε

Αν B >= D τότε

K ← 1

Τέλος_αν

Τέλος_αν

Τέλος_αν

 


 

Διάβασε x, y
ΑΝ x<y τότε

z ← x

αλλιώς

z ← y

Τέλος_αν
Όσο z <> 0 επανάλαβε

z ← x mod y

x ← y

y ← z

Τέλος_επανάληψης

 


Α ← x

Όσο A <= y επανάλαβε

A ← Α + z

Τέλος_επανάληψης


 

Ι ← 2

Όσο Ι<=10 επανάλαβε

∆ιάβασε Α

Εμφάνισε Α

Ι ← Ι+2

Τέλος_επανάληψης


 

δ ← α mod 10

Όσο δ>0 επανάλαβε

δ ← δ − 1

γ ← γ + β

Τέλος_επανάληψης


Χ ← 0

Α ← 10

Β ← 14

ΟΣΟ Β > 0 ΕΠΑΝΑΛΑΒΕ

ΑΝ Β MOD 2 = 0 ΤΟΤΕ

Χ ← Χ + Α

ΤΕΛΟΣ_ΑΝ

Α ← Α * 2

B ← B DIV 2

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


 

Χ ← Κ

Y ← L

Αν Χ < Υ τότε

ΤΕΜΡ ← Χ

Χ ← Υ

Υ ← ΤΕΜΡ

Τέλος_αν

Όσο Υ<>0 επανάλαβε

ΤΕΜΡ ← Υ

Υ ← Χ ΜOD Y

Χ ← TEMP

Εμφάνισε Χ, Υ

Τέλος_επανάληψης

Υ ← (Κ * L) DIV X

Εμφάνισε Χ, Υ


 

Α ← 1

Β ← 1

Ν ← 0

Μ ← 2

Όσο Β < 6 επανάλαβε

Χ ← Α + Β

Αν Χ MOD 2 = 0 τότε

Ν ← Ν + 1

αλλιώς

Μ ← Μ + 1

Τέλος_αν

Α ← Β

Β ← Χ

Εμφάνισε Ν, Μ, Β

Τέλος_επανάληψης

Εμφάνισε Χ


 

Διάβασε α

k ← 2

Όσο α>1 επανάλαβε

Αν α mod k = 0 τότε

Εμφάνισε k

α ← α div k

Αλλιώς

k ← k+1

Τέλος_αν

Τέλος_επανάληψης


Κ ← 1

Χ ← –1

i ← 0

Όσο Χ<7 επανάλαβε

i ← i + 1

Κ ← Κ * Χ

Εμφάνισε Κ, Χ

Αν i mod 2 = 0 τότε

X ← X + 1

Αλλιώς

X ← X + 2

Τέλος_Αν

Τέλος_επανάληψης


x ← 15
κ ← 1
Όσο x<18 επανάλαβε
      x ← x + κ
      Αν x mod 3 = 0 τότε
             κ ← κ + 2
      Αλλιώς
             κ ← κ + 1
      Τέλος Αν
Τέλος_Επανάληψης

 


 

Για Ι από 1 μέχρι 9 με_βήμα 3

Εμφάνισε Ι

Τέλος_επανάληψης


 

Για i από 99 μέχρι 1 με_βήμα -2

x ← i^2

εμφάνισε x

Τέλος_επανάληψης


 

Κ ← 1
ΓΙΑ i ΑΠΟ –1 ΜΕΧΡΙ –5 ΜΕ_ΒΗΜΑ –2

Κ ← Κ * i

ΓΡΑΨΕ Κ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


 

S ← 0

Για Ι από 2 μέχρι 100 με_βήμα 2

S ← S + I

Τέλος_επανάληψης

Εμφάνισε S


 

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100

ΑΝ i MOD 2 = 0 ΤΟΤΕ

ΕΜΦΑΝΙΣΕ i

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


Διάβασε Μ

Για Χ από 3 μέχρι Μ – 1 με_βήμα 2

Α ← 2 * Χ + 4

Β ← 4 * Χ – 3

Αν (Β – Α < 0) ή (Α > 15) τότε

Α ← Α + 5

Β ← Β * 2

Τέλος_αν

Εμφάνισε Α, Β

Τέλος_επανάληψης


 

Α ← 0

Β ← 0

Γ ← 0

∆ ← 0

Για Ε από 1 μέχρι 496

∆ιάβασε Ζ

Αν Ε = 1 Τότε Η ← Ζ

Α ← Α + Ζ

Αν Ζ≥18 Τότε

Β ← Β + Ζ

Γ ← Γ + 1

Τέλος_Αν

Αν Ζ > 0 Τότε ∆ ← ∆ + 1

Αν Ζ < Η Τότε Η ← Ζ

Τέλος_Επανάληψης

Θ ← Α / 496

Αν Γ ≠ 0 Τότε Ι ← Β / Γ

Κ ← 496 – Γ


 

x ← 0

Αρχή_επανάληψης

x ← x + 1

Εμφάνισε x

μέχρις_ότου x = Κ


 

S ← 0

Ι ← 2

Αρχή_επανάληψης

Ι ← Ι + 2

S ← S + I

μέχρις_ότου Ι = 100

Εμφάνισε S


 

Α ← 10

Β ← 20

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

Β ← Β + Α

ΓΡΑΨΕ Α, Β

ΜΕΧΡΙΣ_ΟΤΟΥ Β > 50


 

Α ← 101

Β ← 0

Αρχή_επανάληψης

Β ← Β + Α

Α ← Α + 2

Μέχρις_ότου Α>200

Εμφάνισε Β


 

j ← 1

i ← 2

Αρχή_επανάληψης

i ← i + j

j ← i – j

Εμφάνισε i

Μέχρις_ότου i ≥ 5


 

Αν x>1 τότε

y ← x

Αρχή_επανάληψης

y ← y – 2

Εμφάνισε y

Μέχρις_ότου y ≤ 0

Τέλος_αν


 

Σ ← 0

Κ ← 0

Αρχή_Επανάληψης

∆ιάβασε Χ

Σ ← Σ + Χ

Αν Χ>0 τότε

Κ ← Κ + 1

Τέλος_Αν

Μέχρις_ότου Σ>1000

Εμφάνισε Χ


 

Μ ← 0

Αρχή_επανάληψης

∆ιάβασε α

Αν όχι(α>0) τότε

Μ ← Μ + 1

Τέλος_αν

Μέχρις_ότου α>0

Αν Μ = 0 τότε

Εμφάνισε “Σωστό”

Τέλος_αν

Χ ← 1

Όσο Χ<5 επανάλαβε

Α ← Χ + 2

Β ← 3 * Α – 4

C ← Β-Α+4

Αν Α > Β τότε

Αν Α > C τότε

MAX ← A

αλλιώς

MAX ← C

Τέλος αν

αλλιώς

Αν Β > C τότε

MAX ← Β

αλλιώς

MAX ← C

Τέλος αν

Τέλος αν

Εμφάνισε Χ, Α, Β, C, MAX

Χ ← Χ + 2

Τέλος επανάληψης


 

Διάβασε Α

Β ← 4

C ← 2

Aρχή_επανάληψης

Β ← (Β^2) – 2

Εμφάνισε Β

C ← C + 1

Μέχρις_ότου C > (A – 1)

D ← (2^A) – 1

E ← B mod D

Εμφάνισε D

Αν E = 0 τότε

F ← (2^(C – 1)) * D

Εμφάνισε “Τέλειος αριθμός:”, F

G ← 0

Όσο F > 0 επανάλαβε

G ← G+1

F ← F div 10

Τέλος_επανάληψης

Εμφάνισε G

Τέλος_αν


 

∆ιάβασε Α

Εκτύπωσε Α

S←1

K←2

Αρχή_επανάληψης

Αν Α MOD K = 0 τότε

Β ← Α DIV K

Αν Κ <> Β τότε

S←S + K+B

Εκτύπωσε Κ, Β

αλλιώς

S←S + K

Εκτύπωσε Κ

Τέλος_αν

Τέλος_αν

Κ←Κ+1

Μέχρις_ότου Κ > Ρίζα (Α)

Αν Α = S τότε

Εκτύπωσε S

Τέλος_αν


 

Ι ← 0

Όσο Ι <= 9 επανάλαβε

J ← I

Όσο J <= 9 επανάλαβε

Γράψε ‘Α’

J ← J + 1

Τέλος_επανάληψης

Ι ← Ι + 1

Τέλος_επανάληψης


 

Για Ι από 0 μέχρι 4

Γράψε ‘Α’

Για J από 0 μέχρι 6

Γράψε ‘Α’

Τέλος_επανάληψης

Τέλος_επανάληψης


 

Για i από 1 μέχρι 100

Για j από 1 μέχρι 100

Αν i = 50 τότε

Εμφάνισε i, j

Τέλος_αν

Τέλος_επανάληψης

Τέλος_επανάληψης


 

∆εδομένα //α,β//
Αν α>β τότε

γ ← α

α ← β

β ← γ

Τέλος_Αν

γ ←  0
Όσο α>0 επανάλαβε
δ ← α mod 10
Όσο δ>0 επανάλαβε
δ ← δ − 1
γ ←  γ + β
Τέλος_επανάληψης
α ←  α div 10
β ← β*10
Τέλος_επανάληψης
Αποτελέσματα //γ//

α ← 5

β ← 3

Για Χ από 2 μέχρι 7 με_βήμα 4

Όσο α ≤ 10 επανάλαβε

β ← β + α

α ← α + 4

Τέλος_επανάληψης

Εμφάνισε α, β

α ← 4

Τέλος_επανάληψης

Εμφάνισε α

 


 

∆ΙΑΒΑΣΕ x, n

m ← n

pow ← 1

z ← x

ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ

ΟΣΟ (m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ

m ← m DIV 2

z ← z * z

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

m ← m – 1

ΓΡΑΨΕ pow

pow ← pow * z

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ pow


Permanent link to this article: https://pervolischool.edu.gr/computer-science/algorithms-aepp/repeatif/logical-expression-for-revision/