000000proxeiro

 

ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΓΕΝΙΚΩΝ ΛΥΚΕΙΩΝ
ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ
ΕΝΟΤΗΤΑ: ΠΙΝΑΚΕΣ ΤΙΜΩΝ – ΕΠΙΠΕΔΟ 1
ΘΕΜΑΤΑ ΕΞΕΤΑΣΕΩΝ

Θέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2ο
 



  • Δίνεται ο παρακάτω αλγόριθμος:

     

    Αλγόριθμος ΘέμαΒ

    z 1

    w 3

    Όσο z<=35 επανάλαβε

    zz+w

    ww+2

    Γράψε w,z

    Τέλος_επανάληψης

    Tέλος ΘέμαΒ

     

    Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του αλγορίθμου με τη σειρά που θα εμφανιστούν.

  •  

  •  

  •  

 



  • ∆ίνεται το παρακάτω τμήμα αλγορίθμου:

    Κ1

    Χ –1

    i 0

    Όσο Χ<7 επανάλαβε

    ii + 1

    ΚΚΧ

    Εμφάνισε Κ, Χ

    Αν i mod 2=0 τότε

    XX+1

    Αλλιώς

    XX+2

    Τέλος_Αν

    Τέλος_επανάληψης

     

    Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

    (Απ:-1, -1 ~ -1, 1 ~ -2, 2 ~ 8, 4 ~ -40, 5)

 



  • Δίνεται τo παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές. Θεωρήστε ότι οι τιμές που εισάγονται είναι ακέραιες και μεγαλύτερες του μηδενός.

    1. ΔΙΑΒΑΣΕ x, y

    2. ΑΝ x < y ΤΟΤΕ

    3. z ← x

    4. ΑΛΛΙΩΣ

    5. z ← y

    6. ΤΕΛΟΣ_ΑΝ

    7. ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ

    8. z ← xMODy

    9. x ← y

    10. y ← z

    11. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    Β1. Να αναπαραστήσετε με διάγραμμα ροής το παραπάνω τμήμα αλγορίθμου.

    Μονάδες 6

    Β2. Δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

    αριθμός γραμμής x y z
    1 150      35                 
           

    Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.

    Στη συνέχεια του πίνακα υπάρχει μια στήλη για κάθε μεταβλητή του αλγορίθμου.

    Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε, εκτελώντας τις εντολές του τμήματος αλγορίθμου για x = 150 και y = 35 ως εξής:

    Για κάθε εντολή που εκτελείται να γράψετε σε μία νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμα της εκτέλεσης της εντολής.

    Σημείωση: Στον πίνακα τιμών έχει συμπληρωθεί η εκτέλεση της πρώτης εντολής του αλγορίθμου.

    Μονάδες 10

 



  • Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές:

    1. j ← 1

    2. i← 2

    3. Αρχή_επανάληψης

    4. i←i + j

    5. j←i – j

    6. Εμφάνισε i

    7. Μέχρις_ότου i ≥ 5

    Επίσης δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

     

     

     

     

     

     

     

     

    αριθμός γραμμής

    συνθήκη

    έξοδος

    i

    j

     

     

     

     

     

     

     

     

    Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.

    Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.

    Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.

    Στη συνέχεια του πίνακα υπάρχει μια στήλη για κάθε μεταβλητή του αλγόριθμου.

    Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε εκτελώντας τις εντολές του τμήματος αλγορίθμου ως εξής:

    Για κάθε εντολή που εκτελείται να γράψετε σε νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμά της στην αντίστοιχη στήλη.

    Σημείωση: Η εντολή της γραμμής 3 δεν χρειάζεται να αποτυπωθεί στον πίνακα.

    Μονάδες 20

 



  • Δίνεται ο παρακάτω αλγόριθμος, στον οποίο έχουν αριθμηθεί οι εντολές εκχώρησης:

    Αλγόριθμος Πολλαπλασιασμός

    Δεδομένα //α, β//

    Αν α>β τότε αντιμετάθεσε α, β

    1 γ0

    Όσο α>0 επανάλαβε

    2 δα mod 10

    Όσο δ>0 επανάλαβε

    3 δδ-1

    4 γγ+β

    Τέλος_επανάληψης

    5 αα div 10

    6 ββ*10

    Τέλος_επανάληψης

    Αποτελέσματα //γ//

    Τέλος Πολλαπλασιασμός

     

    Επίσης δίνεται υπόδειγμα πίνακα (πίνακας τιμών), με συμπληρωμένες τις αρχικές τιμές των μεταβλητών α,β (τιμές εισόδου), καθώς και της εντολής εκχώρησης με αριθμό 1.

    Αριθμός Εντολής

    α

    β

    γ

    δ

     

    20

    50

     

     

    1

     

     

    0

     

     

    Α. Να μεταφέρετε στο τετράδιό σας τον πίνακα και να τον συμπληρώσετε, εκτελώντας τον αλγόριθμο με αρχικές τιμές α=20, β=50 (που ήδη φαίνονται στον πίνακα).

    Για κάθε εντολή εκχώρησης που εκτελείται να γράψετε σε νέα γραμμή του πίνακα:

    α. Τον αριθμό της εντολής που εκτελείται (στην πρώτη στήλη).

    β. Τη νέα τιμή της μεταβλητής που επηρεάζεται από την εντολή (στην αντίστοιχη στήλη).

    Μονάδες 10

    Β. Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με την εντολή:

    Αν α>β τότε αντιμετάθεσε α, β

    χωρίς να χρησιμοποιήσετε την εντολή αντιμετάθεσε.

    Μονάδες 5

    Γ. Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα:

    δα mod 10

    Όσο δ>0 επανάλαβε

    δδ-1

    γγ+β

    Τέλος_επανάληψης

    χρησιμοποιώντας αντί της εντολής Όσο την εντολή Για. Στο νέο τμήμα αλγορίθμου να χρησιμοποιήσετε μόνο τις μεταβλητές α,β,γ,δ, που χρησιμοποιεί το αρχικό τμήμα.

    Μονάδες 5

     

 



  • Δίνεται το παρακάτω τμήμα αλγορίθμου:

    Χ2

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    YX DIV 2

    ZA_M(X/3)

    ΑΝ Ζ>0 ΤΟΤΕ

    ΑZ

    ΑΛΛΙΩΣ

    ΑΥ

    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ Χ, Υ, Ζ, Α

    ΧΧ+3

    ΜΕΧΡΙΣ_ΟΤΟΥ Χ>10

     

    α. Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών που θα εμφανιστούν σε κάθε επανάληψη.

    Μονάδες 12

    β. Να μετατρέψετε το παραπάνω τμήμα αλγορίθμου σε ισοδύναμο με χρήση της δομής επανάληψης ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ…ΜΕ_ΒΗΜΑ.

    Μονάδες 8

     

 



  • Δίνεται το παρακάτω τμήμα αλγορίθμου:

    Χ0

    Α10

    Β14

    ΟΣΟ Β>0 ΕΠΑΝΑΛΑΒΕ

    ΑΝ Β MOD 2 = 0 ΤΟΤΕ

    ΧΧ+Α

    ΤΕΛΟΣ_ΑΝ

    ΑΑ*2

    BB DIV 2

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    α. Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Χ, Α και Β στο τέλος κάθε επανάληψης κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου.

    Μονάδες 12

    β. Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής.

    Μονάδες 8

    (Απ α. 10, 20, 7 ~ 10, 40, 3 ~ 10, 80, 1 ~ 90, 160, 0)

     

 



  • Α. Δίνεται το παρακάτω τμήμα αλγορίθμου:

     

    Χ2

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ Χ MOD 4 > 2 ΤΟΤΕ

    ΧΧ+2

    ΑΛΛΙΩΣ

    ΧΧ+3

    ΤΕΛΟΣ_ΑΝ

    ΕΜΦΑΝΙΣΕ Χ

    ΜΕΧΡΙΣ_ΟΤΟΥ Χ>15

     

    α. Ποιο είναι το πλήθος των επαναλήψεων που θα εκτελεστούν;

    Μονάδες 2

    β. Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Χ που θα εμφανιστεί σε κάθε επανάληψη.

    Μονάδες 10

    γ. Ποια είναι η τελική τιμή της μεταβλητής Χ;

    Μονάδες 2

     

 



  • Δίνεται το παρακάτω τμήμα αλγορίθμου:

    Διάβασε Μ

    Για Χ από 3 μέχρι Μ-1 με_βήμα 2

    Α2*Χ+4

    Β4*Χ-3

    Αν (Β-Α<0) ή (Α>15) τότε

    ΑΑ+5

    ΒΒ*2

    Τέλος_αν

    Εμφάνισε Α,Β

    Τέλος_επανάληψης

    Να γράψετε τις τιμές των μεταβλητών Α και Β που εμφανίζονται κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου, όταν για Μ δώσουμε την τιμή 9.

    (Απ:15, 18 ~ 14, 17 ~ 23, 50)

 



  • Δίνεται το παρακάτω τμήμα αλγορίθμου όπου οι μεταβλητές Κ, L, M είναι ακέραιες:

    K35

    L17

    M0

    OΣΟ L>0 ΕΠΑΝΑΛΑΒΕ

    ΑΝ L MOD2 = 1 TOTE

    MM+K

    ΤΕΛΟΣ_ΑΝ

    ΚΚ*2

    LL DIV 2

    TEΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΕΜΦΑΝΙΣΕ Μ

    α) Να συμπληρώσετε τον παρακάτω πίνακα

      Κ Λ Μ
    ΑΡΧΙΚΕΣ ΤΙΜΕΣ 35 17 0

    1η επανάληψη

    70 8 35
    2η επανάληψη 140 4  
    3η επανάληψη 280 2  
    4η επανάληψη 560 1 595
    5η επανάληψη 1120 0  

    Μονάδες 15

    β) Για ποια τιμή της μεταβλητής L τερματίζει ο αλγόριθμος;

    Μονάδες 3

    γ) Ποια είναι η τελική τιμή της μεταβλητής Μ;

    Μονάδες 2

 



  • ∆ίνεται ο παρακάτω αλγόριθμος:

    Αλγόριθμος ΘέμαΒ

    z 1

    w 3

    Όσο z<=35 επανάλαβε

    zz+w

    ww+2

    Γράψε w,z

    Τέλος_επανάληψης

    Tέλος ΘέμαΒ

     

    Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του αλγορίθμου με τη σειρά που θα εμφανιστούν.

 



  • ∆ίνεται το παρακάτω τμήμα αλγορίθμου:

    Κ1

    Χ –1

    i 0

    Όσο Χ<7 επανάλαβε

    ii + 1

    ΚΚΧ

    Εμφάνισε Κ, Χ

    Αν i mod 2=0 τότε

    XX+1

    Αλλιώς

    XX+2

    Τέλος_Αν

    Τέλος_επανάληψης

     

    Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

    (Απ:-1, -1 ~ -1, 1 ~ -2, 2 ~ 8, 4 ~ -40, 5)

ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΓΕΝΙΚΩΝ ΛΥΚΕΙΩΝ
ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ
ΕΝΟΤΗΤΑ: ΠΙΝΑΚΕΣ ΤΙΜΩΝ – ΕΠΙΠΕΔΟ 2
ΘΕΜΑΤΑ ΕΞΕΤΑΣΕΩΝ

Θέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2ο
 



  • Δίνεται το παρακάτω τμήμα αλγόριθμου:

    α 5

    β 3

    Για Χ από 2 μέχρι 7 με_βήμα 4

    Όσο α < =10 επανάλαβε

    β β + α

    α α + 4

    Τέλος_επανάληψης

    Εμφάνισε α, β

    α 4

    Τέλος_επανάληψης

    Εμφάνισε α

    Να γράψετε στο τετράδιό σας τις τιμές που εμφανίζονται κατά την εκτέλεση του παραπάνω τμήματος αλγόριθμου.

    Μονάδες 10

  •  

  •  

  •  

 



  • Επαναλ Εσπ – 2013

    Να σχεδιάσετε στο τετράδιό σας τον πίνακα Π μαζί με τις τιμές, που θα έχει μετά την εκτέλεση του παρακάνω αλγορίθμου.

 



  • Δίνεται ο µονοδιάστατος πίνακας C µε έξι στοιχεία που έχουν αντίστοιχα τις παρακάτω τιµές: 2, 5, 15, –1, 32, 14 και το παρακάτω τµήµα αλγορίθµου:

     

    min 100

    max –100

    Για i από 1 µέχρι 6 µε_βήµα 2

    Α← C[i]

    B ← C[i+1]

    Αν A<Βτότε

    Lmin← A

    Lmax← B

    αλλιώς

    Lmin←Β

    Lmax Α

    Τέλος_αν

    Αν Lmin<min τότε

    minLmin

    Τέλος_αν

    Αν Lmax>max τότε

    maxLmax

    Τέλος_αν

    Εκτύπωσε Α, Β, Lmin, Lmax, min, max

    Τέλος_επανάληψης

    Dmax*min

    Εκτύπωσε D

     

    Να εκτελέσετε το παραπάνω τµήµα αλγορίθµου και να γράψετε στο τετράδιό σας:

    α. Τις τιµές των µεταβλητών Α, Β, Lmin, Lmax, min και max, όπως αυτές εκτυπώνονται σε κάθε επανάληψη.
    (Απ: 2, 5, 2, 5, 2, 5~15, -1, -1, 15, -1, 15~32, 14, 14, 32, -1, 32)

    Μονάδες 18

    β. Την τιµή της µεταβλητής D που εκτυπώνεται.
    (Απ: -32)

    Μονάδες 2

 



  • Δίνεται ο παρακάτω αλγόριθµος:

    Αλγόριθµος Αριθµοί_ ΜΕΡΣΕΝ

    Διάβασε Α

    Β 4

    C ← 2

    Aρχή_επανάληψης

    Β (Β^2) – 2

    Εµφάνισε Β

    C ← C + 1

    Μέχρις_ότου C> (A – 1)

    D ← (2^A) – 1

    E ← B MOD D

    Εµφάνισε D

    Αν E = 0 τότε

    F ← (2^(C – 1)) * D

    Εµφάνισε "Τέλειος αριθµός:", F

    G ← 0

    Όσο F> 0 επανάλαβε

    G ← G + 1

    F ← F DIV 10

    Τέλος_επανάληψης

    Εµφάνισε G

    Τέλος_αν

    Τέλος Αριθµοί_ΜΕΡΣΕΝ

     

    Να γράψετε στο τετράδιό σας τις τιµές που τυπώνει ο παραπάνω αλγόριθµος, αν του δώσουµε τιµές εισόδου:
    α. 3 (Μονάδες 12)
    (Απ: 14 ~ 7 ~ Τέλειος αριθμός : 28 ~ 2)

    β. 4 (Μονάδες 8)
    (Απ: 14 ~ 194 ~ 15)

ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΓΕΝΙΚΩΝ ΛΥΚΕΙΩΝ
ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ
ΕΝΟΤΗΤΑ: ΠΙΝΑΚΕΣ ΤΙΜΩΝ – ΕΠΙΠΕΔΟ 3
ΘΕΜΑΤΑ ΕΞΕΤΑΣΕΩΝ

Θέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 1οΘέμα 1οΘέμα 1οΘέμα 1οΘέμα 1ο
 



  • Δίνεται παρακάτω ένα πρόγραμμα με ένα υποπρόγραμμα:

    ΠΡΟΓΡΑΜΜΑ Υπολογισμοί

    ΜΕΤΑΒΛΗΤΕΣ

    ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ

    ΑΡΧΗ

    ΔΙΑΒΑΣΕ α, β

    γ α+ Πράξη (α, β)

    ΓΡΑΨΕ γ

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

     

    ΣΥΝΑΡΤΗΣΗ Πράξη (χ, ψ): ΠΡΑΓΜΑΤΙΚΗ

    ΜΕΤΑΒΛΗΤΕΣ

    ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ

    ΑΡΧΗ

    ΑΝ χ >= ψ ΤΟΤΕ

    Πράξη χ – ψ

    ΑΛΛΙΩΣ

    Πράξη χ + ψ

    ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

     

    α. Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία αντί συνάρτησης.

    Μονάδες 7

    β. Να ξαναγράψετε το πρόγραμμα που δόθηκε αρχικά, ώστε να επιτελεί την ίδια λειτουργία χωρίς τη χρήση υποπρογράμματος.

    Μονάδες 7

    γ. Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του αρχικού προγράμματος που δόθηκε, αν ως τιμές εισόδου δοθούν οι αριθμοί:

    i. α = 10 β = 5 ii. α = 5 β = 5 iii. α = 3 β = 5
    (Απ: 15 ~ 5 ~ 11)

    Μονάδες 6

  •  

  •  

  •  

 



  • Ημερ – 2011

    Δίνεται τo παρακάτω πρόγραμμα και ένα υποπρόγραμμα:

     

    Πρόγραμμα ΘέμαΒ

    Μεταβλητές

    Ακέραιες: z,w

    Αρχή

    z ← 1

    w ← 3

    Όσο z<=35 επανάλαβε

    Κάλεσε Διαδ(z,w)

    Γράψε z

    Τέλος_επανάληψης

    Tέλος_Προγράμματος

    Διαδικασία Διαδ(w,z)

    Μεταβλητές

    Ακέραιες: z,w

    Αρχή

    w ← w+z

    z ← z+2

    Γράψε z

    Τέλος_Διαδικασίας

     

    Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος με τη σειρά που θα εμφανιστούν.

    (Απ:5, 4 ~ 7, 9 ~ 9, 16 ~ 11, 25 ~ 13, 36)

    Μονάδες 10

     

 



  • Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα.

    Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος.

     

    ΠΡΟΓΡΑΜΜΑ Κλήση_Υποπρογραμμάτων

    ΜΕΤΑΒΛΗΤΕΣ

    ΑΚΕΡΑΙΕΣ: α, β, χ

    ΑΡΧΗ

    α 1

    β 2

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ α<= 4 ΤΟΤΕ

    ΚΑΛΕΣΕ Διαδ1(α, β, χ)

    ΑΛΛΙΩΣ

    χ Συν1(α, β)

    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ α, β, χ

    ΜΕΧΡΙΣ_ΟΤΟΥ χ>11

    ΓΡΑΨΕ χ

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

     

    ΔΙΑΔΙΚΑΣΙΑ Διαδ1 (λ, κ, μ)

    ΜΕΤΑΒΛΗΤΕΣ

    ΑΚΕΡΑΙΕΣ: κ, λ, μ

    ΑΡΧΗ

    κκ+1

    λλ+3

    μκ+λ

    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

     

    ΣΥΝΑΡΤΗΣΗ Συν1(ε, ζ): ΑΚΕΡΑΙΑ

    ΜΕΤΑΒΛΗΤΕΣ

    ΑΚΕΡΑΙΕΣ: ε, ζ

    ΑΡΧΗ

    ζ ζ+2

    ε ε*2

    Συν1 ε+ζ

    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

     

    (Απ: 4, 3, 7 ~ 7, 4, 11 ~ 7, 4, 20 ~ 20)

    Επανάληψη

    Μεταβλητές

    Συνθήκες

    Μεταβλητές

    Μεταβλητές

     

    Έξοδος

     

    α

    β

    χ

    α<=4

    χ>11

    λ

    κ

    μ

    ε

    ζ

    Συν1

    α

    β

    χ

     

    1

    2

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    1<=4 Α

     

    1

    2

     

     

     

     

     

     

     

     

    4

    3

    7

     

    6>11 Ψ

    1+3=4

    2+1=3

    3+4=7

     

     

     

    4

    3

    7

     

     

     

    4<=4 Α

     

    4

    3

    7

     

     

     

     

     

     

     

    7

    4

    11

     

    10>11 Ψ

    4+3=7

    3+1=4

    4+7=11

     

     

     

    7

    4

    11

     

     

     

    7<=4 Ψ

     

     

     

     

    7

    4

     

     

     

     

     

     

     

    20

     

    19>11 Α

     

     

     

    7*2=14

    4+2=6

    14+6=20

    7

    4

    20

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    20

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    Κατά την εκτέλεση του προγράμματος θα εμφανιστούν οι τιμές:

    4, 3 ,7 κατά την 1η επανάληψη

    7, 4, 11 κατά την 2η επανάληψη

    7, 4, 20 κατά την 3η επανάληψη

    και 20 εκτός επανάληψης

 



  • Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα:

     

    ΠΡΟΓΡΑΜΜΑ Κύριο

    ΜΕΤΑΒΛΗΤΕΣ

    ΑΚΕΡΑΙΕΣ: Α, Β, Γ

    ΑΡΧΗ

    ΔΙΑΒΑΣΕ Α, Β, Γ

    ΚΑΛΕΣΕ Διαδ1(Α, Β, Γ)

    ΓΡΑΨΕ Α, Β, Γ

    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

     

    ΔΙΑΔΙΚΑΣΙΑ Διαδ1(Β, Α, Γ)

    ΜΕΤΑΒΛΗΤΕΣ

    ΑΚΕΡΑΙΕΣ: Α, Β, Γ

    ΑΡΧΗ

    ΑA + 2

    ΒB-3

    ΓΑ + Β

    ΓΡΑΨΕ Α, Β, Γ

    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

     

    Τι θα εμφανιστεί κατά την εκτέλεση του προγράμματος, αν ως τιμές εισόδου δοθούν οι αριθμοί 5, 7, 10;

     

 



  • Δίνεται το παρακάτω τμήμα προγράμματος και μια συνάρτηση:

     

    Διάβασε Κ

    L 2

    A 1

    Όσο Α < 8 επανάλαβε

    Αν Κ MOD L = 0 τότε

    Χ Fun(A, L)

    αλλιώς

    Χ Α + L

    Τέλος_αν

    ΕμφάνισεL, A, X

    A A + 2

    L L + 1

    Tέλος_επανάληψης

    ……………

    Συνάρτηση Fun(Β, Δ) : Ακέραια

    Μεταβλητές

    Ακέραιες: Β, Δ

    Αρχή

    Fun (B + Δ) DIV 2

    Tέλος_συνάρτησης

     

    Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών L, A, X, όπως αυτές εκτυπώνονται σε κάθε επανάληψη, όταν για είσοδο δώσουμε την τιμή 10.

    (Απ:2, 1, 1 ~ 3, 3, 6 ~ 4, 5, 9 ~ 5, 7, 6 )

     

ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΓΕΝΙΚΩΝ ΛΥΚΕΙΩΝ
ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ
ΕΝΟΤΗΤΑ: ΠΙΝΑΚΕΣ ΤΙΜΩΝ – ΕΠΙΠΕΔΟ 4
ΘΕΜΑΤΑ ΕΞΕΤΑΣΕΩΝ

Θέμα 2οΘέμα 2οΘέμα 2οΘέμα 2οΘέμα 1οΘέμα 1οΘέμα 1οΘέμα 1οΘέμα 1οΘέμα 1ο
 



  • Ποια τα αποτελέσματα κατά την εκτέλεση των εντολών του αλγορίθμου που ακολουθεί:

    Αλγόριθμος sudoku

    Ν 5

    k 1

    Για i από 1 μέχρι Ν

    k i

    Για J από 1 μέχρι 6-i

    A[i,j] k

    k k+1

    Τέλος_επανάληψης

    Αν k>5 τότε

    Για w από 1 μέχρι i-1

    A[i,j] w

    j j+1

    Τέλος_επανάληψης

    Τέλος_Αν

    Τέλος_επανάληψης

    Αποτελέσματα //A//

    Τέλος sudoku

  •  

  •  

  •  

 



  • Ο μονοδιάστατος αριθμητικός πίνακας Table έχει τα ακόλουθα στοιχεία:

     

    1η θέση

    2η θέση

    3η θέση

    4η θέση

    5η θέση

    43

    72

    -4

    63

    56

    Δίνεται το παρακάτω τμήμα αλγορίθμου :

    Για Ι από 2 μέχρι 5

    Για J από 5 μέχρι Ι με_βήμα -1

    Αν Table[J-1] < Table[J] τότε

    Αντιμετάθεσε Table[J-1], Table[J]

    Τέλος_αν

    Τέλος_επανάληψης

    Τέλος_επανάληψης

     

    Να μεταφερθεί στο τετράδιό σας ο ακόλουθος πίνακας και να συμπληρωθεί για όλες τις τιμές του J, που αντιστοιχούν σε I=2 και Ι=3.

     

    Πίνακας

    Ι

    J

    2

    5

    43

    72

    -4

    63

    56

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    3

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

 



  • Δίνεται μονοδιάστατος πίνακας Α, 10 θέσεων, ο οποίος στις θέσεις 1 έως 10 περιέχει αντίστοιχα τους αριθμούς:

    15, 3, 0, 5, 16, 2, 17, 8, 19, 1

    και τμήμα αλγορίθμου:

    Για I από 1μέχρι9 με_βήμα 2

    k←((i+10) mod 10)+1

    Α[i]←Α[k]

    εκτύπωσεi, k, A[i], A[k]

    Τέλος_επανάληψης

     

    Ποιές τιμές τυπώνονται με την εντολή εκτύπωσεi, k, A[i], A[k] καθώς εκτελείται το παραπάνω τμήμα αλγορίθμου;

    (Απ:1, 2, 3, 3 ~ 3, 4, 5, 5 ~ 5, 6, 2, 2 ~ 7, 8, 8, 8 ~ 9, 10, 1, 1)

 



  • Δίνεται ο πίνακας Α (σχήμα 1) και το παρακάτω τμήμα προγράμματος:

    sum←0

    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5

    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5

    ΑΝ i = j TOTE

    sum ←sum + A[i,j]

    AΛΛΙΩΣ

    A[i,j]←0

    Τέλος_αν

    Τέλος_επανάληψης

    Τέλος_επανάληψης

    γραψε sum

    Αυτό το τμήμα προγράμματος χρησιμοποιεί τον πίνακα Α, με τις τιμές των στοιχείων του, όπως αυτές φαίνονται στο σχήμα 1.

    1

    -1

    7

    1

    1

    6

    2

    0

    8

    -2

    4

    9

    3

    3

    0

    3

    5

    -4

    2

    1

    0

    1

    2

    0

    1

    Σχήμα 1: Πίνακας Α

    1. Να σχεδιάσετε στο τετράδιό σας τον πίνακα Α με τις τιμές που θα έχουν τα στοιχεία του, μετά την εκτέλεση του τμήματος προγράμματος.

    Μονάδες 15

    2. Ποια είναι η τιμή της μεταβλητής sum που θα εμφανιστεί; (Απ: 9)

    Μονάδες 5

     

Permanent link to this article: http://pervolischool.edu.gr/000000proxeiro/